Problem installing firmware

SystemSystem Posts: 19Administrator
This discussion was created from comments split from: New to 3D printing.

Comments

  • sja454sja454 Posts: 3Member
     good morning  I just received my first 3D printer. I purchased the JGMaker Magic. While I was setting it up, I learned that I should update the firmware. (It printed right out of the Box, however it needs some fine tuning). I followed the video instructions that I found on this wiki site (great video) but when I tried verifying before uploading I got the following error. (I tried 2 different computers with same results)


    Arduino: 1.8.12 (Windows 10), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

    C:\Users\Roliena\AppData\Local\Temp\cczFXH6f.ltrans0.ltrans.o: In function `main':

    C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/main.cpp:43: undefined reference to `setup'

    C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/main.cpp:46: undefined reference to `loop'

    collect2.exe: error: ld returned 1 exit status

    exit status 1
    Error compiling for board Arduino Mega or Mega 2560.

    I am pretty sure I followed the instructions correctly. I am not very computer literate and am brand new to the 3D printing world!!  Any help would be appreciated 
  • Samuel PinchesSamuel Pinches Posts: 2,597Administrator
    The first thing to check is that you opened the "marlin.ino" file, not the main.cpp file - I realise that may be counter-intuitive. That should then open up the full marlin firmware project, with many tabs visible.
  • sja454sja454 Posts: 3Member
    I was able to complete the update tonight!!!!  I haven't tried it yet-waiting on some filament, but it said done uploading...  What I did different was this:  when I first tried uploading the custom firmware I clicked on the link on the wiki page.  It took me to a zip folder that I down loaded on my computer, then clicked through until it was unzipped.  I then scrolled down the list until I found the Arduino file.  I clicked on it and it auto opened Arduino.  When I hit verify I received the above error messages (original post).  I tried updating Windows and all my drivers and tried the same approach with the same results.  Tonight I opened Arduino, then selected open from the menu and found the unzipped folder containing the custom firmware.  I selected the Arduino file and verified it.  It worked!!  I then connected my JGMaker and selected upload.  it worked!!!  Hopefully filament is here Thursday and I can try it out....  Sorry for the simple, non-techy language, I am a paramedic not a programmer!!
  • Stephen ToddStephen Todd Posts: 281🌟 Super Member 🌟
    Clicking through a zipped folder would not usually do anything but access the files individually

    What you should do is download a zip file to your desktop, then right click on it and select "Extract All" - at that point you can forget the zip file - you now have a new folder with "normal" files inside

    Same process when you download a zip file containing a printable object from thingiverse - you unzip the file to get at the STL, printing instructions, and photos of the object
    Thanked by 1Samuel Pinches
Sign In or Register to comment.