Firmware

Hi guys! I owned a A5 and recently changed the motherboard to a MKS GEN 1.4 because the previous one was spoilt.
However when i tried to flash the custom firmware today, an error saying "unknown motherboard value set in config.h" prompt out.
I did changed the motherboard in config.h to suit my gen 1.4 board.

So i was wondering does the custom firmware support the Gen 1.4 board? If it does, do you have any idea why did the error prompt out? If it doesn't, should i get a different motherboard?

Im quite a noob when it comes to stuff like this hence any help would be very much appreciated! :)

Comments

  • Samuel PinchesSamuel Pinches Posts: 2,597Administrator
    edited May 19
    Welcome @bhjt1728 - what was the old motherboard value, and what did you change the new one to?

    The standard A5 motherboard is the MKS Gen L (not the SGen L, please don't confuse them)

    It should be changed in configuration.h from:
      #define MOTHERBOARD BOARD_MKS_GEN_L
    to
      #define MOTHERBOARD BOARD_MKS_13

    Hope this helps. The list of supported boards for this specific build of marlin is listed in the file boards.h



    Thanked by 1bhjt1728
    Post edited by Samuel Pinches on
  • bhjt1728bhjt1728 Posts: 5Member
    Hi Samuel, 

    I did changed the define motherboard to the one that suits my current motherboard which is the same as what you mentioned and it prompt out the unknown motherboard error.

    The funny thing is i tried again today and it worked. 

    However my main problem, which i thought that would be solved after i flashed the software still persists. I have already uploaded a video on Youtube for reference and i will create another forum post for it. I hope you can take a look at my video and perhaps give me some advice. 

    Thanks again!


Sign In or Register to comment.