A5 Problem

Hi guys. 

I have encountered a problem with my A5 and hope to get some help from you guys. The title of my post is very very vague as i do not know how to label/ specify the exact problem. However i do have a video uploaded on youtube to make it easier to understand. 

Basically i changed my motherboard to a MKS Gen 1.4 since my previous one was spoilt. Didn't flashed a firmware after setting up the cables which made my printer go crazy. (See Vid) Flashed the custom firmware hoping that the problem will now be solved but the problem still persist.

Video Link: https://www.youtube.com/watch?v=t5uF5hAZWV0

I got a feeling that the problems lies with the xyz coords settings which is currently messed up.

Any help or advice given will be very much appreciated. Thanks in advance :)

Comments

  • Samuel PinchesSamuel Pinches Posts: 2,597Administrator
    Ok. There's a lot going on here. How do you know that the flash was successful? Can you connect the printer to pronterface, and then after you connect to the printer, can you please copy the log into a post here.
  • Samuel PinchesSamuel Pinches Posts: 2,597Administrator


  • bhjt1728bhjt1728 Posts: 5Member
    Hey Samuel, 

    I managed to fix that crazy jamming problem with my printer today. The previous time, i just uploaded the firmware and didn't connect it through pronterface afterwards, simpleminded me thought that if the firmware could be uploaded to the printer on marlin, it meant that it was a success. 

    Today i decided to give it another try. Since i noticed that the direction of the axis is currently reversed, i swapped the current TRUE/FALSE settings for the X,Y,Z & E0 in the firmware. I proceeded then to connect the printer on pronterface but for some reason i could not control/test my printer through pronterface. Clicked on the home/axis button but my extruder won't move.

    Hence i disconnected the printer from pronter and simply plug the main power cable to the socket. Switched on the printer and pressed the Home function and it actually worked! The extruder managed to be positioned at where it was supposed to be. :smile:  

    However, i ended up with 2 new problems again :(

    1) My extruder is not heating up, it is stuck at 78C and would not go up. Nothing wrong with the thermistor i guess since it isnt 0C or -15C, connections are fine too.

    2)The extrude function isnt working. Tried feeding filament in the printer but the printer isnt responding.

    Could these problems be related to the fact that i could not test my printer using pronter? I captured a printscrn of what i believe is the pronterface log that you mention before and i hope this helps. 

    I look forward to your reply and thanks as always!
  • Samuel PinchesSamuel Pinches Posts: 2,597Administrator
    I'm very confused ... are you sure you are flashing the 1.1.8C firmware from the wiki? You should not have to change anything! If you are not flashing the correct firmware you will get all kinds of issues. Cheers.
    Thanked by 1bhjt1728
  • bhjt1728bhjt1728 Posts: 5Member
    Yes i have checked and made sure that is the correct firmware. Might try to re-flash the firmware again when i have the time, hopefully both of the new problem that i have will be resolved. 
Sign In or Register to comment.