A5 :: Bed Heating Problem

Hi to all,
this morning I printed a small object with my A5 without problems from the USB flash drive, so I prepared the second (with Cura) but it never starts because the bed did not want to warm up.
The display sometimes showed 25, sometimes 26 degrees Celsius, I realized it was the temperature of the room.
I tried to force the heating of the bed from the display but nothing! always the same room temperature.
I tried to heat a cup of water and put it in any place on the bed, hoping to see any variation on the display, but the temperature never changed.
So I unscrewed the bed, lifted it up a bit and found the connector burned out.

So I used a hot air gun on the connector because it seemed glued; so I disassembled the bed and there was practically a black pin on the bed , and on the connector like if it had melted.




What do you suggest to do?

I thought about doing:
1- clean the burnt pin with a file
2- try to measure the impedance 1-2 and 3-4 and compare it with the value in another post that I found today to check if the bed is still usable

Does this make sense...:
Q1- replace the connector with one that can support a lot of current. (like some small RC / XT60 lipo connectors)?
Q2- change the whole cable with an AWG16 silicone cable?

...??

Thanks inadvance


MuT

Comments

  • rhaub101rhaub101 Posts: 78🌟 Super Member 🌟
    That is a known problem with the 4 pin connector. You can change the bed and cable to a 6 pin connector that will carry more current or you can remove the 4 pin connector and solder the wires directly to the bed (that was my choice)
  • Laser8302Laser8302 Posts: 162Member, 🌟 Super Member 🌟
    if you solder the wires to the bed, make sure you leave a little wire for strain relief.
  • PetrTecillaPetrTecilla Posts: 1Member
    edited July 24
    Hi....just assembled it and was printing PLA for one week without any issues. Yesterday I wanted to try my first print with ABS and I am always getting preheat errors at around 95-97° bed temperature. Already checked all connections and also did slightly increase the voltage of the PSU from 12.15 to 12.35 without any effect.

    rush turn pcb assembly in canada
    Post edited by PetrTecilla on
  • Samuel PinchesSamuel Pinches Posts: 2,668Administrator
    Welcome @PetrTecilla -- what temperature is it in your printing room? Have you upgraded the fan? What fan speed are you using? Best, Sam
  • Samuel PinchesSamuel Pinches Posts: 2,668Administrator
    edited July 21
    @PetrTecilla -- also, the PSU voltage should be 24V not 12V?? Has someone replaced the PSU in your A5?
    Post edited by Samuel Pinches on
Sign In or Register to comment.