my jgaurora a5 not powering up

i have jgaurora a5 and it not powering up at all, 
i tried to tear it down, and tested the power supply output it show zero  volts, i thought it is a power supply issue, so i replaced it with a new one. the same problem still..
so i disconnected the output wires that refers to mainboard and and the power supply worked..
now i realized it is an issue with the mainboard 
  
do anyone have any idea how to diagnose this case? 
could this be fixed by replacing a component such a fuse or a resistor or any thing else than the mainboard ?

Comments

  • abodejomabodejom Posts: 2Member
    well.. i just figured it out...
    it turns out that the heat bed is dead.. 
    i,v disconnected the heat bed wires and it powered up  
  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    heat bed may be short circuited ... or maybe bed heating mosfet on motherboard has failed short. If you have a multimeter you can check resistance of all bed connections.
  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    welcome @abodejom
  • Laser8302Laser8302 Posts: 160Member, 🌟 Super Member 🌟
    repair the short and it should work fine again. The power supply has good short circuit protection.
    Thanked by 1Samuel Pinches
Sign In or Register to comment.