JGMaker is having a CLEARANCE sale on the commercial-grade Z-603S -- at a BONKERS $399. If you're in the USA, and want a ready-to-go full steel frame printer... run, don't walk! ⏩ JGAURORA Z603S CLEARANCE ⏪ Only 4 units left!

A5S Bed gets "stuck" during printing

Hello all!

I just bought a used A5S that has a known layer shift problem.

I ran a number of prints of a vase (sized to x=45mm y=45mm and z=320mm) using JGCreat, then Cura (with Spiral mode active) with various results (see below for test print results and observations)

From what I observed, I feel it's a mechanical issue, not software. The previous owner did put this machine through its paces, up until the layer shifting began. (He was gifted a new printer so repairing this one wasn't a priority for him.)

Ideally, I'd like to know what the issue might be and fix it. However, given the price I paid for the printer and the price of replacement parts, I'm willing to purchase new parts to replace what I think are the mechanisms controlling the y-axis (print bed).

For the sake of information sharing, if anyone has an idea of what could be causing this, I welcome your input.

As for my approach to solving this issue, I am going to opt for a full replacement of the y-axis movement. Again, if anyone has experience in doing this, please share details (parts, procedure, caveats, etc.)

Thanks!

---

TEST PRINT RESULTS

PRINT #1: printed completely, with three layer shifts.
- Firmware 2019-??-?? ??:??:??
- Sliced with JGCreat with 0.2mm layer height.
- 1st shift occurs at ~270.0mm. The print shifts towards the front of the piece by 1.0mm.
- 2nd shift occurs at ~285.0mm. The print shifts towards the back of the piece by 0.8mm.
- 3rd shift occurs at ~317.0mm.  The print shifts towards the back of the piece by 1.3mm.
- Looking at the left and right sides fo the print, the surface is very smooth, which says to me that the x-axis (print head) is printing accurately.
- However, the front and back of the print are not as smooth, having an almost rippled texture if looked at its profile, which says to me the y-axis (print bed) has accuracy issues.

PRINT #2: printed completely, with one layer shift.
- Firmware 2019-??-?? ??:??:??
- Sliced with Cura with A5S profile at 0.2mm layer height
- Shift occurs at ~70.0mm. The print shifts towards the back by 1.4mm.
- There are additional shifts for the next 8 layers, each layer shifting towards the back by 0.2mm, ending in a total shift towards the back by 2.5.
- Print continues through the end.
- Left and right sides are smooth. Front and back also show signs of smaller, very imperceptible shifts.

PRINT #3: print is stopped at ~187.0mm.
- Firmware 2019-??-?? ??:??:??
- Reprinted same exact file as PRINT #2.
- No layer shift, but...
- Print bed stops moving.
- x- and z- axes continue to function.
- A slight nudge to the print bed gets the bed moving again, but print is canceled.

PRINT #4: print is stopped at ~159.0mm
- Updated firmware to 2020-06-22 15:38:43 prior to printing.
- Sliced with Cura with layer shifting setting tweaks as suggested in the "Layer Shifting" page in the wiki.
- No layer shift, but...
- Print bed stops moving (again)
- x- and z- axes continue to function
- Again, a slight nudge to the print bed gets it moving again. (Print is canceled afterward.)
- During this print, there is considerable noise (almost squeaky) coinciding with bed movement.



Comments

  • Samuel PinchesSamuel Pinches Posts: 2,904Administrator
    Sounds like the y-axis bearings might be troublesome?


    Thanked by 1CapFive
  • ArwolfArwolf Posts: 1Member
    I had the same problem and the cause was the Y stepper motor. I removed the motor and dismantled it them re-lubricated the two bearing and the problem went away but if you don't want to follow my steps then just change the motor.
  • Samuel PinchesSamuel Pinches Posts: 2,904Administrator
    Welcome, and thanks @Arwolf
  • CapFiveCapFive Posts: 15Member
    edited September 2020
    Thanks @Samuel Pinches and @Arwolf

    So is the squeaky, grinding noise coming from the bed movement is due to the linear bearings, which I'm assuming are worn out? 

    And the bed getting "stuck"  during printing is due to bearings in the y-axis stepper motor requiring lubrication?

    Can the bearings be lubricated to restore them to working condition? What's the best lubricant to use? What should be avoided? (For instance, WD-40 is frowned on for applications like this.) Ignore these comments... just found the page "Lubricants & Grease" page (link) on the wiki. Great info in there!
     
    How "tricky" is it to dismantle a stepper motor to lubricate the bearings inside?

    I was originally going to just replace the affected components. However, if lubrication saves the day, I am willing to try it out. (If I flub it, I'll just go ahead with my original plan to buy replacement components anyway!)

    I appreciate the assist!
    Post edited by CapFive on
  • Samuel PinchesSamuel Pinches Posts: 2,904Administrator
    Generally a stepper motor should not require lubrication. Just the bearings that the y-carriage rides on.
    :-)
  • CapFiveCapFive Posts: 15Member
    @Samuel Pinches ... good to know!

    I just picked up a tube of Super Lube at a local Harbor Freight.

    Time to open up this A5S and see what kind of mess I'm gonna make! 

    Stay tuned...
    Thanked by 1Samuel Pinches
  • CapFiveCapFive Posts: 15Member
    Update on my y-axis refurbishment...

    I spent a good amount of time working on those bearings.

    I submerged and agitated the bearings in a warm water/dish detergent solution. There was a good show of sediment. I dried them off and applied Super Lube on the inside of the bearings.

    But it didn't improve the condition of the bearings as I had hoped it would.

    Actually two of the four bearings moved somewhat freely. Not as freely as I'd see in videos, but I figure it might be enough. However, the remaining two bearings were stubborn. You can hear and feel them grinding on the rod and required some effort to move them along. Plus, they would only rotate in one direction. The other two could rotate somewhat easily.

    In the meantime, I ordered a replacement set of bearings from Amazon (link). If I went about working these bearings the wrong way, I welcome any corrections. I don't mind trying out another method on the existing bearings. If it works out, I can return the incoming bearings or save 'em for something else!
  • CapFiveCapFive Posts: 15Member
    Replacement y-axis bearings from Amazon have arrived!

    I'll install these and get another test print going to see if cures my layer shift issue...!


  • CapFiveCapFive Posts: 15Member
    SUCCESS!!! 

    The new linear bearing kept the bed moving smoothly and quietly for the smoothest print the A5S has made since I got it.

    For my next mod, I'm thinking of trying the BLTouch upgrade. 

    Thanks to everyone who helped out.
    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Posts: 2,904Administrator
    Woo hoo! Congrats! Hopefully from here its happy printing.
    Thanked by 1CapFive
  • CapFiveCapFive Posts: 15Member
    A  little update on the stuck bed...

    The first test print after replacing the bearings printed beautifully. My next print didn't fare as well.

    After working through some adhesion issues, the bed still gets stuck. I noticed it would stop in relatively the same spot - roughly in the middle of the length of the bottom case. Homing the y-axis didn't work either. A gentle push on the bed re-enabled movement again. Running another print and it would get stuck again in the same spot.

    I opened the bottom case again and checked the bearings. The bed rails slide along the linear rod without a problem. So that wasn't the problem. 

    Now, when I had replaced the bearings, I noticed the belt attached to the y-axis motor looked a little slack. So I tightened the post (which held the belt on the opposite side of the motor) to the aluminum crossbar that also supports the ends of the linear rods.

    So, I was thinking that the belt may be TOO tight. I didn't recall how much slack there was initially, so it was trial and error for a bit. However, I think I may have found the sweet spot.

    At first, I used various items to act as spacers. Nothing I used worked. What worked was to slowly tighten the screws of the post until it would no longer turn with the slightest effort.

    I have run the same print twice with no shifting.

    I'm gonna say it's fixed... for now!

    (I hope this helps out for anyone else with y-axis layer shifting issues.)
    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Posts: 2,904Administrator
    Thanks @CapFive for following up with the details of what's required to finesse a sticking bed!
  • GreysLawGreysLaw Posts: 4Member
    Sounds similar to my experience i described here https://jgauroraforum.com/discussion/511/jgaurora-a5s-layer-shifting Esp. regarding the noise, which I thought came from the bearings but was almost all due to the belt catching on the flats of the pulley. I'm glad it works for you, but if it happens again take a look at the angles in the belt and the general state of it.

  • CapFiveCapFive Posts: 15Member
    Hello all... I forgot a major follow up to my stuck bed issue.

    After the recent belt adjustment, my smaller test prints worked well. Taller prints? Not so much.

    I opened up the printer again and removed the stepper motor. At this point, I was going to replace it. So I figured there'd be no harm to take apart this motor. Spinning the rotor, I could feel it "clicking" as if the gears were catching on something. I opened it and saw some sediment on the rotors. (I hope I'm referencing these parts correctly.) I wiped it clean and reassembled the motor. Spinning the rotor again, it surprisingly spun much, MUCH more smoothly. (I did not add and grease to the motor.) I reinstalled the motor, reattached the belt as I had recently done, and prepared for another print.

    BINGO!

    Not only do I not get any more layer shifting (And I've been printing tall, full-sized masks!), the printer is now much quieter.

    It was a journey getting this printer fixed, but I am thrilled with how this printer is producing!

    (Oh, one more tip... when reattaching the brass standoffs, do NOT over tighten them. They will snap. I snapped one and I was luckily able to remove it and reattach it with a spot of CA glue.)
  • GreysLawGreysLaw Posts: 4Member
    Hey CapFive, looks  alot like the problem i was having indeed.  When did you purchase your printer? i can imagine this being a series problem as the same motor subassembly may be used in multiple pinters. did you check out the belt profile? mine was almost gone, i hope yours fared better.  glad to hear you are printing again
  • CapFiveCapFive Posts: 15Member
    Hey Grey... I picked up the printer thru Craigslist. The layer shifting was a known problem when I got it. (It supposedly ran fine until the issue occurred about a month prior to its listing.)

    But I did check the belt as part of the whole repair routine. The belt and pulley looked fine. Although I can see how those parts can be attributed to the issue.
Sign In or Register to comment.