New community firmware 2.0G for A5S, A1 and A3S - with new touch interface!

Samuel PinchesSamuel Pinches Posts: 2,836Administrator
edited February 16 in Modifications & Upgrades
Hi all,
Just a quick announcement, I've just released new firmware version 2.0G for JGAurora/JGMaker's 32-bit 3D printer lineup, including the A5S, the A1, and the A3S with the front SD card. This firmware has a brand new user interface that uses the latest Marlin ColorUI development.
Please try and enjoy! :smiley:
Merry Christmas & Happy New Year
Sam




Thanked by 1Tobscin
Post edited by Samuel Pinches on

Comments

  • TobscinTobscin Posts: 3Member
    This is great, thank you!

    I have to compile it by my own, because i have a 3DTouch/BLTouch. Did you upload the source code, so i can use it?
    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    I haven’t uploaded 2.0G yet. Coming in two weeks, I’m on holiday now 😂
  • buklbukl Posts: 9Member
    Very cool. Thanks a lot for the effort!
    Some toughts:
    • The Bootscreen says 2.0F
    • I don´t like the new bed level behaviour of staring every point at 5mm. It might be usefull for the first point, but after that the old version of taking the last hight made more sense. With the high start point i held the down button and overshot for almost every point
    • New UI and saving to CPU are great
    • Best new feature: Filament runout sensor works!
    Again, thanks for the great work.
    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    edited January 25
    2.0G Firmware source code published
    Source code for 2.0G with new colour touch UI build now published on github if you want to build yourself and tinker with firmware. Supports filament run out, and saving of settings to CPU flash.

    Post edited by Samuel Pinches on
  • Hole23Hole23 Posts: 5Member
    Great. Just tried and it works fine.

    Am I the only one with a non calibrated touch? To use this interface (and all the old versions of non-original firmware) I have to touch half cm left to the button that I want to select. There's the lcd calibration function on the official firmware that solves this. Is there a way to add this function?

    I just noticed that JGAurora on its official firmware download page now links to the custom community firmware...no more "original" firmware
  • EyeEye Posts: 50Member
    Is there  a new verion for the a5 WITHOUT S too?

  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    edited February 5
    @Hole23 -- sorry, I'll need to look into adding a calibration interface. I also have no idea why JGAurora has copied my firmware to their site?? Nobody asked me for sure.

    @Eye - unfortunately not for the A5. No real new features of note for 8-bit boards, and I am not doing TMC mods so I can't test those kinds of features. However, it is fairly trivial to make a new build for A5 -- I'm happy to help anyone who wants to take over this role for the community, but it's not going to be something I will be championing on my own any more, especially as I no longer have an A5 printer.
    Post edited by Samuel Pinches on
  • EyeEye Posts: 50Member
    edited February 6
    I am an It guy, but  the last  Programming   language i felt at home was TP 7 ;)

     with help of that video  just so made  it to  the update process ;) 
    how more "fairly trivial" is it? ;)

     Also i have   LOTS of troubel with the   leveling,  so much that the moment the A5 gets something i cant fix WILL be one with    autobedleveling ;) - so my hope was that the New version with the different  was of Stepping would be  Helpfull ;)

    I take the  described nozel is the more pointy one?

    tried  some of those, with the old hot end assemblage and That did  not work well, had to   rise the Z endstop and such,.. ;)

    AT the moment i use a  Steel nozzle; and if clogged; i   Basically  burn it  red glowing and its clean ;)




    Post edited by Eye on
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    @Eye -- I think your english is good enough, that it would be quite straight forward. I am very happy to teach a person how to do it, if that person wants to continue to help others with this task too.

    Do you have problems even with mesh bed levelling?

    Steel nozzle sounds easier to clean indeed :D :D :D :D
  • ManolineManoline Posts: 1Member
    hola amigos del forum, tengo una Jgaurora A5S y he tenido algún corte eléctrico y con el nuevo firmware la impresora no vuelve a iniciar la impresión que estaba haciendo, me gustaria saber si hay algun error en firware o existe alguna configuracion que no haya visto, gracias.
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    edited February 13
    Hi @Manoline , I’m sorry but this firmware does not support power fail feature. Only the firmware from the manufacturer.
    Post edited by Samuel Pinches on
  • bouchardhbouchardh Posts: 7Member
    HI,I've compiled and installed your latest firmware on A5S and I get this on screen when I do the bed leveling:
    Buttons work as expected. I am unsure as to how to check if bed leveling is active... After bed level, z was set at -0.1 and moving it to 0, I get about a bit over paper thickness I used to level the bed. I was thinking that I should set Z to 0.1 to check the distance between nozzle and bed... I admin that I never checked it that way but it is in your procedure for bed mesh leveling.

    Something I do not understand?

    Thank you for your the firmware, I will keep testing the beta.
  • EyeEye Posts: 50Member
    Samuel Pinches,    Helping others is the   Basis for   community's is it not? ;)
     What would be needed  To  adapt the fw  for a5?
     
     An i only have one;) So how much risk is that i need a new board? ;)

    Yes Steel nozzle,  something   to hold it so you do not  burn yourselves and then  ad energy,.. 
    Careful not dripping  burning plastic  on yourself,.. 
    so far the steel thing works since a year+  and  the plastic stuff burns away very nicely ;)

    I am looking into a  replacement throat  now Tht owuld  alo the same

    To the Mesh leveling  problem 
     i have  25 Meshing points  and   often  after i save  The  leveling, the  printer tells me he could not engage the bed leveling,..
     i started  now to input Save several times ,

    Tried It also with pronterface for a while

    So far i  have   changed the Z-line end stop Plastic thingy  with a longer  version  due  to  i  could not  lift the  z-axes high enough, With some  more pointy replacement nozzles  
    had to  exsaged   Termisteror  and   Heat Bullet,..
    Replaced  the   small fans with larger more silent ones and had To replace those  stepper Chips on the  Board ...
    Most times the upper   fan is not connected ;

     ( Lots of Cabel clamps; verry ugly

     Then     i have a printed  protection chain to the   cabel on  the side...  

    So i would   Hate to brick all of that   and have to get an other printer ,)

     








  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    @Eye , to be clear, a new firmware for A5 will not change the touch interface. It will only change the software on the main board. Is this acknowledged? To change the interface on A5, you would need to replace the MKS TFT28 screen module, with a standard Marlin 128x64 LCD.

    If this is ok, and you still want to be the manager for new firmware for the A5, please start a new thread and I can help you get started. The risk to damaging the A5 motherboard is near-zero, if the proper steps are followed. The LCD must be disconnected during flashing -- if this is followed, there is not much that can go wrong.
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    welcome @bouchardh -- the instructions for mesh bed levelling were written for the 2.0D beta, and have not yet been updated for the 2.0G version. I'm sorry I have not had time to spend on this lately.
  • bouchardhbouchardh Posts: 7Member
    @Samuel Pinches Fair enough... I've been doing some more printing with the new firmware as I am exploring some other slicers (been using Cura since day one with my first printer) as I am refining a box for a roller shutter controller.

    The SD card was write protected and that might have had something to do with it... So, redid the bed level, option came back set to On and I could feel the Z screws moving slightly as the head moves and got a perfect first layer.

    Only thing is, I got multiple filament change messages at different spots while printing. I checked the code just in case and nothing. My guess is that the filament runout detector is triggering for nothing. The good news is that I had no issue putting the filament back in and print resumed without much artifacts.

    How can I remove if from the build? Looking at the documentation, I would guess -UHAS_FILAMENT_SENSOR in the build_flags but not sure.

  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    edited February 15
    @bouchardh - In file /Marlin/Marlin/configuration.h, line 1216, comment out the line.

    I'm pretty sure its poor shielding of long wires from stepper motor noise on the machine causing spurious, non-debounced readings on the filament sensor pin.

    Thanked by 1bouchardh
    Post edited by Samuel Pinches on
  • EyeEye Posts: 50Member
    edited February 16
    Samuel Pinches  i am aware that the A5 display  has its own  firmware and that  the  display  needs to be disconnected  so the  Main firmware update Can Get were it needs to 

     Does the "New" Work with the Stock display and The old update?
    at the moment i am on 
    JG A5 Custom Main Marlin Firmware - 1.1.8C
    JG A5 Custom LCD Firmware - v3.03



    Post edited by Samuel Pinches on
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    edited February 16
    @Eye - we can make a new firmware for the A5 main board (1.1.8C --> 2.x) if you are interested, which will be compatible with the LCD firmware (v.3.03). Please start a new thread for this, as I don't want to confuse this A5S thread.
    Post edited by Samuel Pinches on
  • bouchardhbouchardh Posts: 7Member
    @Samuel Pinches That worked like a charm. Printer is usable now. Flashing the firmware also erases the saved bed mesh so I had to redo it all. Measured the skirt and I got .2-.24 on a .25 first layer. All in all, it was a decent print. I noticed that you have configuration - A5S.h in there but I guess it is not used.

    Still have same problem with the '-', '+' and check mark graphics. Anything specific you need testing with?
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    edited February 16
    >Still have same problem with the '-', '+' and check mark graphics
    Could you please explain further?

    There are no known issues on this firmware at present. Open to suggestions for improvements though. I don't plan to implement power-outage-detection at this stage.
    the configuration.h is preconfigured for A5S, but I consider the -A5S and -A1 as the master ones to copy into the configuration.h for compiling the firmware on different machines.

    Post edited by Samuel Pinches on
  • bouchardhbouchardh Posts: 7Member
    @Samuel Pinches see picture above, white square instead of '-', white bar under check mark.
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    edited February 16
    Sorry, I didn't even notice that! 😂

    Do you get the same error flashing my  pre-compiled 2.0G? Does the functionality work ignoring the graphical glitch?
    Post edited by Samuel Pinches on
  • bouchardhbouchardh Posts: 7Member
    I will check today.
  • EyeEye Posts: 50Member
    How shall i Name the threat?
  • bouchardhbouchardh Posts: 7Member
    Using the pre-compiled binary, the graphical glitch is not there. Buttons work fine even though the graphic is not right with the one I compiled. I will clean all. I am compiling the jgaurora_a5s_color_ui branch.
  • bouchardhbouchardh Posts: 7Member
    @Samuel Pinches Exact same graphics glitches with the one I compiled. Since I need it to prevent the filament sensor from generating false positive, it will do.

    I had EEPROM.DAT on the SD card just in case it was causing issues with firmware.
  • Samuel PinchesSamuel Pinches Posts: 2,836Administrator
    @bouchardh -- sounds like you are doing things correctly. I will have to investigate further, I'm sorry I cannot give an ETA at this stage.
    Thanked by 1bouchardh
Sign In or Register to comment.