A5S dead after 2 years: buzzer, heater and dark screen

I have an A5S bought on Amazon in 2018, working well with some fiddling, until yesterday.  I took the hot end apart because of some extrusion issues.  When I put it back together, I got a constant buzzer, and the extrusion heater was on.  The LCD says "FAT Mount Fail," then "Enter FW" (I did not copy down the exact messages).  The screen goes white, then black, with the buzzer blasting.  After a few seconds the system shuts down.  If I keep trying, the interval to shutdown gets shorter.

Opening the case, the STM32 feels warmer than I expect, but not super hot.  I never touched it before so do not know what is normal there.  One time I got the normal LCD screen by powering up while pressing the white button on the control board, but the buzzer was still going. 

The control board says "A3S A5S A1 Main Control V1.1" 11/21/2018

Reading that heater shorts sometimes cause this kind of thing, I disconnected the hot lead of the extrusion heater at the control board.  That also stopped the heater from smoking off its old skin of melted PLA.  No effect.  The bed heater cable is intact but I don't know where to disconnect it to be sure.

"A5S firmware - 20200622.zip" does not load.  I tried two different SD cards, also tried extracting the ZIP.  With SD card inserted, the LCD says "FAT Mount OK" then "FW Load Fail", then proceeds as above. 

I have ST-Link and jgaurora A1_full_flash_clone.bin from another thread.  Is it reasonable to JTAG this board, or does the problem sound more electrical?

Comments

  • Samuel PinchesSamuel Pinches Posts: 2,844Administrator
    edited January 6
    Welcome @lslarry86 !

    The zip needs to be extracted to work. Try a 32GB or smaller SD. Format as fat32, not exfat. 

    Flashing via ST-link will work, but I think is unlikely to fix a problem.
    I suggest to try my latest 2.0g beta on firmware.jgmakerwiki.com
    Post edited by Samuel Pinches on
  • Samuel PinchesSamuel Pinches Posts: 2,844Administrator
    The printer has a large super cap on the board. Make sure you wait 20 seconds with power off fully, before you do a reboot, otherwise you may get errors, or a white screen.
  • Samuel PinchesSamuel Pinches Posts: 2,844Administrator
    If all doesn’t work, may need to replace motherboard. 🙁
  • lslarry86lslarry86 Posts: 4Member
    Thanks for the tips.  I'm using a 2GB Kingston micro SD in an adapter.  FAT32 format, ZIP extracted. 
  • lslarry86lslarry86 Posts: 4Member
    I went a little further with this, taking the LCD panel loose so I could move the top plate aside.  I also unplugged the longest external connector, from Z Endstop to Hot End Heater.  All the same symptoms happen.  First try this morning, I got a screen, so the firmware is still in there.  The screen painted very slowly, tile by tile.  The STM32 became too hot to touch within a few seconds, mostly in the center.  Next try, no display - the system shut down before the screen painted.

    Is this a common failure of the control board?


  • Samuel PinchesSamuel Pinches Posts: 2,844Administrator
    Honestly, I really don’t know. I haven’t seen any boards fail in this way before. I suspect you could just replace the main motherboard with a replacement from the manufacturer, I suspect the display panel part is fine.
  • Samuel PinchesSamuel Pinches Posts: 2,844Administrator
    I suspect there may have been a short circuit to a thermistor that has fried the cpu in some way
  • lslarry86lslarry86 Posts: 4Member
    A thermistor shorted to case can fry the CPU?  That probably happened, good info.

    The boards on the spare parts page don't look like my board.  I think I can replace the CPU.  Does that seem reasonable?
  • Samuel PinchesSamuel Pinches Posts: 2,844Administrator
    It most likely is just the CPU, but I guess it seems like a deeper rabbit hole to me than I would personally go down -- I would just contact JGMaker and buy a replacement board. :disappointed:
  • MattMatt Posts: 241🌟 Super Member 🌟
    Try changing the innards: the cost is laughable (if you buy things outside from their store...). I would mind if this is a case of "programmed obsolescence".
Sign In or Register to comment.