Z-end stop problem, now damage to printer?

Hi everyone,

I have a JG aurora A-5 and my z-axis end stop must have loosened up and worked it's way down so that the print head impacted the plate.  This happened a few times before I realized what was going on.  I have since moved the end stop back up and the end stop works when I home my printer, but when I use the leveling commands the print head moves to the end stop to the side of the build plate, comes back up, positions itself over the build plate, and then attempts to move below the end stop.  The right side of the print head gantry is physically stopped by the end stop, but the left side tries to keep moving.  This causes the print head to impact the print bed, and the two sides of the print head gantry to misalign.  Now when I run the z axis manually the screws vibrate, the left and right motors don't seem to step evenly... 

Does anyone know why the print head homes correctly, but tries to keep going with the leveling function, and also what parts I may need to replace to get the motors and screws working smooth again?  I have checked the Z axis end stop, there doesn't appear to be any issues with it now that I have it moved back up.  I also tried to re-install the firmware to see if that fixed anything.  I believe I correctly updated it, but the problem is still ocurring.

Thanks,
Falcore

Comments

  • Samuel PinchesSamuel Pinches Posts: 2,844Administrator
    edited January 30
    Welcome Falcore,
    How frustrating! :disappointed:
    I would suggest to try slow down the homing feedrate. Try and replace the following files, and reupload your firmware one more time. Make sure you do M502 & M500 after flashing.
    I suspect electrical noise from the z-motors could be affecting the Z-endstop function, hopefully going slower using the following configuration files could solve it.
    Best ,
    Sam
    Post edited by Samuel Pinches on
  • FalcoreFalcore Posts: 3Member
    Sam,

    I uploaded the firmware with the configuration files you provided and had the same issue, but I think I know what is going on now. 

    I believe that when I use the bed leveling command on the A5, the print head moves to the z stop to the side of the print surface.  It then raises up and moves to the the selected leveling location.  It appears that once it is in position it is then moving down the equivalent amount it moved up from the end stop.  I believe on my printer that since the Z axis has been damaged in some way, the print head is not moving up all the way when it begins movement to re-position for leveling, but is moving down the full amount.  Since it is not traveling all the way up, but is traveling all the way down, the print head continues to impact the build plate.  It does not appear to be using the z stop for the leveling motion after it checks it to the side of the build plate.  This obviously makes me think the real issue is my Z axis and not the end stop.  I think I will order some new motors and get some lubrication for the threaded rods.

    These are the ones listed in spare parts for the A5.  Are these correct for the Z axis:
    https://de.aliexpress.com/item/32855037727.html?spm=a2g0x.12010612.8148356.53.7e4277a1ecV8IQ

    I will need to measure, but I think the ones I want are the 34 mm version.  Is this correct?  Is there a better motor available I should consider?
  • Samuel PinchesSamuel Pinches Posts: 2,844Administrator
    edited February 10
    Most likely the issue is just lubrication. The grease gets sticky over time and that is a very common issue. I would hold off on the motors (very reliable!!) until you've cleaned off and relubed.
    Post edited by Samuel Pinches on
  • FalcoreFalcore Posts: 3Member
    The cleaning and re-lube of the threaded rods solved the problem.  Thank you for the help.
    Thanked by 1Samuel Pinches
Sign In or Register to comment.