JGMaker is having a CLEARANCE sale on the commercial-grade Z-603S -- at a BONKERS $399. If you're in the USA, and want a ready-to-go full steel frame printer... run, don't walk! ⏩ JGAURORA Z603S CLEARANCE ⏪ Only 4 units left!

First Impressions

Hi,

yesterday I got an e-mail announcing my delivery of my JG Maker Artist-D in 3 to 6 days. I checked the code and found the box was send two days earlier and scheduled that same day (now yesterday).

Putting the printer together was straight forward. I struggled a little bit to get the gantry in place and all screws in. Later I found one of the lose cable connector was stuck under the gantry. That may have caused my struggle.

The handbook told me bed should be leveled. It was by far not level. The screws in the front left and the back right jam a bit more than the string can push. I must lose some more and push the bed up. On the way down, I than can set up the level.

I do have some issues with the firmware:

When I first had loaded only one filament into E1 (= no Filament in E2) a change filament started for E1 in that’s home position. That filled the wire brush with plastic. After the first print the extruder went back into that blob of plastic. A next try to move E1 it was stuck in that blob of plastic. I had to get the brush out and clean it using a soldering iron.

After printing with E2 (only or as last extruder) x-home or home bumps E2 into E1 casing some ugly rattling. It does not matter how I home: via screen, gcode from file or octoprint. The firmware is a development build, so I hope there is someone developing. I will try updating it.

Offset between E1 and E2 was off, although the handbook tells it was set. On the first try the two colors separated immediately. It took me some iterations to get them aligned. But I will redo that after I got the print settings tuned.

The SD card came with a user manual, a useless ...download file in a video folder, a old Version of Cura and some stl files. I used the files from Dual-color mixed testing to check the tools offset.

In need of a Cura profile:

Having a newer Cura running, I used that. I am very much missing some (good) settings. The first prints where bad. I took the speed and movement settings from my Ender 3 pro. With them the results are good. I will start experimenting.

PLA sticks extremely to the bed. Even after cooling down it takes me some effort to get the print of that bed.

The fans run as soon as the printer is turned on. They are loud and noisy. I hardly hear the Artist-D printing. I can work next to my Ender 3 pro, but not next to Artist-D.

 

Summary:

Mechanical:

- Two bed leveling screws jam: JG Maker may have to fix production.

Software (?):

- E1 should not 'auto' change filament when E2 is empty and not used.

- From time to time the menus are exited and some strange movement of the bed occur. (No clue what happens!)

Inconvenience:

- A Cura print profile is missing

- Noisy fans

 

I expected this printer will have to mature here. So by now I am satisfied.

 

Heiko

Thanked by 1Samuel Pinches

Comments

  • naPSnaPS Posts: 3Member
    I just set mine up last night.  I can echo all your observations.

    I actually ripped part of the build surface off of the metal plate underneath it trying to remove a print from it.  I will most likely try to find a piece of coated glass that is the same size as the build plate so I don't have to deal with this in the future.  It sticks too good!  :)  I'm also going to see if a different style of raft fixes the problem.  I'm using the 'pool' right now.

    As far as Cura profiles, I'm getting great prints using the standard custom profile, with the adjustments from the manual.  The couple of single extruder prints I've done look great.

    I have yet to use the second extruder, getting ready to test that right now.

    The instructions were also wrong about the thumb screws - I was supplied 5, and the instructions call for 7.  I used two of the screws included in place of two of the thumb screws on the spool holder.  I suspect this is what they were for anyway.

    There's a firmware on the offical JGMaker site - not sure if it's updated from the one shipped with the model.  But, there's obvious errors with the one that shipped.  When E2 homes from anywhere but adjacent to the home switch, it's being driven past the switch, and there's a significant grinding.  Also, the comment about the extruders 'colliding' during a filament change is true for me as well.  Hopefully this gets resolved, as I'm concerned my printer will be damaged.

    Why is there a USB cable included with this thing?  There's zero mention of it in the manual, either on the USB or on-line.
    Thanked by 1Samuel Pinches
Sign In or Register to comment.