NEW Budget 3D Printer: JGMaker Magic - here's the best deals at the moment:
- Gearbest: Flash sale for $189
- Banggood Store: Take off $20 with coupon bd5cc5
- Amazon USA - $30 instant discount coupon
[6th Nov 18] The NEW recently released JGAurora A5S is already for sale under $400! Print quality is better than A5 out of the box.
Click here to check out this deal!

Broken steppers?

Hello! I've received my JGAurora A5 last week and calibrated it, everything was fine. I flashed the community firmware and tried to calibrate again, except as soon as I made it go to the first point, I heard a loud clicking noise, as if it tried to get into position when it already was? anyway, I started smelling smoke and immediately turned it off and unplugged it. When I turned it back on, the Y axis and Z axis didn't work at all anymore. The LCD still worked fine, so I'm assuming the board is still intact. I checked the steppers and while I'm no expert, the connection seemed a lot more orangey than say, my bowden stepper (the one shown at the top) I'm assuming the Z axis stepper and Y axis steppers got burnt.


So, which stepper do I get? I know there's links to pieces and parts on here but they don't really look the same. I'm a little lost. I heard the Y axis motor needs to be more powerful? I really don't want to mess this up more than I already have. Also, how do I keep this from happening in the future? Thanks in advance!

Comments

  • Samuel PinchesSamuel Pinches Administrator Posts: 1,618
    edited July 2018
    Hi Jari, welcome to the forum!

    Sorry to hear that things have gone terribly wrong so quick! How disappointing!

    I'd bet that the stepper motors are fine. Takes a fair bit to kill them. Much more likely to be the stepper drivers that have died.

    You can swap the stepper drivers in the working axis with the ones in the broken axis and see if the axis moves then. I would inspect the stepper drivers and the motherboard closely, as they are more likely to have been the source of the burning smell. You could also test the motors this way too - by swapping things around and seeing if they moved when plugged into a working motor's cable.

    First point of call is to find out what is damaged. You also need to check that your printer is still heating properly, test the nozzle and the bed, and make sure they both get up to temperature fine, and are displaying the correct temperatures.

    Then, you can contact your seller and/or JGAurora for warranty replacement parts. If it is the stepper drivers only that have failed, you may just want to source those yourself, to save time and hassle, as A4988 are dirt cheap.
    Post edited by Samuel Pinches on
  • AETEKAETEK 🌟 Super Member 🌟 Posts: 106
    Hello,
    After your error description, I would guess that a limit switch does not work. The collision and further stress could have overloaded a stepper driver. I assume that you have not measured the correct setting of the stepper driver VREF voltage (setting the motor current) before startup. If the value was set too high, then the Stepper Driver can blow. Overheating protection is too slow in this case. Until it reacts it is already too late.
    Therefore, I advise you to check the function of the limit switches (mechanical and electrical).

    Greetings
    AETEK
  • Jari ChristophersonJari Christopherson Member Posts: 9
    edited July 2018
    Thank you all so much for the quick and informative replies! I switched the stepper drivers and now the Z axis works! I can finally move the base out of the printer more easily. The Z axis was stuck at the bottom, which made it really hard to take apart. I'll check to see if the Y axis works too.

    I didn't see any screws on the drivers though, so I'm not sure how I would've been able to tune them? I don't really know where I was supposed to set it otherwise.
    Does that mean I have to get another limit switch, as well as the drivers?
    Post edited by Jari Christopherson on
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,618
    I heard about these non-tuneable drivers yesterday - there’s nothing you can do except replace them if they cause problems.

    You can test the limit switches by hand using pronterface, and by sending command M119 to get the status of all switches, pressed or unpressed.
  • Jari ChristophersonJari Christopherson Member Posts: 9
    I see. Well, i tested the Y axis and it works, however you might be right about the broken limit switch. I used the UI to move it forwards and back, and it looks like it's offset? Like...it's stuck closer to the front, and won't go backwards when there's still space, though when it goes forward it clearly tries to go farther than it can. i'm afraid to press home in case it breaks the one working driver.
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,618
    edited July 2018
    Maybe there is something stuck or blocking it internally?
    Post edited by Samuel Pinches on
  • Jari ChristophersonJari Christopherson Member Posts: 9
    But I can move it around just fine when it's turned off?
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,618
    1. turn printer off
    2. move y-axis all the way to the back, you should here the y-axis limit switch engage.
    3. turn printer on
    4. connect via pronterface
    5. send command M119.
    6. should see "triggered" for y-axis
    7. move axis towards front
    8. send command M119
    9. should see "open" for y-axis
  • Jari ChristophersonJari Christopherson Member Posts: 9
    Alright, I checked with pronterface and it says what you described. does that mean my limit switch is fine?
  • Jari ChristophersonJari Christopherson Member Posts: 9
    edited July 2018
    OK so I replaced the stepper drivers, tuned them up as close as I possibly could according to the tutorial on this site. plugged it in, everything is able to move. turns out the reason the Y axis couldn't move past a certain point is BECAUSE I didn't make it go home. Went on pronterface, checked M119, everything's good.

    the Z axis was too close to the build plate. I lifted it up a little so that the build plate didn't have to be lowered too much...
    Went to level the build plate, loosened  it up a bit...then the black screw things fell off. can't even get them back on anymore. the screw that's attached to the build plate is also loose, as in, it spins freely.
    can something with this printer finally go right? x.x
    Post edited by Jari Christopherson on
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,618
    I'm glad you sorted the endstop problem... so you know, it is #3 on the FAQ page – I'd recommend checking that out for future problems.

    The bed levelling screws have been a complaint a few people have mentioned. That's frustrating, but I'm sorry, I don't know what the deal is, maybe JGAurora is using the wrong type of nut?? 
  • Jari ChristophersonJari Christopherson Member Posts: 9
    edited July 2018
    Alright, I looked online and it said I needed M3 screws. I went to every hardware store in a mile radius and it turns out, nobody has those because it's more of a U.S.A. thing.

    I went "screw it" (no pun intended) and bought the closest equivalent I could find in imperial: 6-32. I knew I needed 40mm of lenght so it was about an inch and a half. I bought washers (I needed split locks but I bought flats instead, d'oh) with it and even springs and a wing nut to replace the stupid knob. SOMEHOW everything fits...but I know I need to be careful with the heat bed. Can anyone tell me if this will cause a short? I've heard something about the springs of the leveling screws being dangerous if they come into contact with the bed. I see the heat element and the washer is touching it. Is it a problem? I'll be frantically refreshing until anyone gives me their approval (or disapproval) for this x.x
    EDIT: so from what I learned, it has to do with the paint scraping off, not just about the metal making contact? but paint has already been scraped off right under the split locks. I'm guessing it's a problem if it touches the heating element while the paint's off? can anyone confirm?
    EDIT#2: I took the original split locks and stretched them with pliers so they fit the new screws. problem solved. The only problem now is that the added space between the surface and the spring made it REALLY HARD to make the screws go through the holes. I was terrified of bending the glass and putting too much stress on the rails when I was pushing them in. I probably bent something but man is it much easier to adjust the levels now.
    Post edited by Jari Christopherson on
Sign In or Register to comment.