NEW Budget 3D Printer: JGMaker Magic - here's the best deals at the moment:
- Gearbest: Flash sale for $189
- Banggood Store: Take off $20 with coupon bd5cc5
- Amazon USA - $30 instant discount coupon
[6th Nov 18] The NEW recently released JGAurora A5S is already for sale under $400! Print quality is better than A5 out of the box.
Click here to check out this deal!

BETA JGAurora A5 Firmware 1.1.9C

Samuel PinchesSamuel Pinches Administrator Posts: 1,623
edited August 2018 in Modifications & Upgrades
At the moment I have a beta version of 1.1.9C for testing. I will release a final version in the next few days for both A5 and A3S once this version has been tested by a few people. Please post here once you have tried it, if it worked for you, or if you had any problems. Thanks!

Remember…

  • UNPLUG LCD BEFORE updating
  • Install the g8ulib library in Arduino
  • After updating, send commands “M502” then “M500” to reset the EEPROM. You will need to perform any levelling process again, or restore any settings you have changed before printing.


New Features:

  • Bed levelling stays on after G28 - still need to use "M420 S1" to turn it on though.
  • Smoother printing in theory with S-curve acceleration turned on.


Current Bugs:

  • I noticed that endstops were disabled after mesh bed levelling - use command M211 S1 then M501 to reenable in pronterface.
Future Todo:
  • Testing and tuning of linear advance - currently disabled



Download here

Follow install instructions here
Thanked by 1cheekieduckie
Post edited by Samuel Pinches on
«1

Comments

  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    I also have a cura profile you can try here. Unzip and import into cura.
    zip
    zip
    sam-a5-profile-pla-aug18.curaprofile.zip
    960B
  • CovaCova Member Posts: 5
    It's been most of a month...  Any updates on this getting past beta status?
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    Hi Cova, 
    Several people have tried it and I have not heard any complaints yet! However, I have just moved house, and I have not had time to perform any further testing and tuning of the linear advance feature yet. Once I get time to get my workshop setup again, I'll be back at it for sure. Were there any specific questions you had about 1.1.9C?
    Cheers,
    Sam
  • CovaCova Member Posts: 5
    Just planning on upgrading to it myself soon, and thinking there must be some kind of known issue even if minor that it hasn't made it past beta in this time.

    When you say "tuning" linear advance - are you actually doing anything to the firmware code?  Or just playing around with different K-factors through M900 commands?
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    edited September 2018
    @Cova  -- When there are known issues, I do try to mention them, but nothing I'm aware of at the moment.

    RE tuning - yes exactly, just changing parameters, no changes to the code. Most people don't do any parameter tuning, so I mention this so they know that it is not yet fully optimised yet.
    Post edited by Samuel Pinches on
  • CovaCova Member Posts: 5
    Well I only have hands-on experience with the older LA algorithm (the one that is still in Prusa's branch of Marlin), but the K value is something that changes based on the filament in use - I wouldn't spend too much time trying to find the perfect value, because it'll be something different for the next person using a different brand and/or material.

    So if that's all it is, I guess I'll grab a copy of the code from above and merge my own config into it and give it a go in the near future.
  • CovaCova Member Posts: 5
    I got 1.1.9 installed on the A5 a little while ago - first test print is still in progress.

    Thoughts so far - besides the newer version, when I compiled it this time I enabled PROBING_HEATERS_OFF which I didn't have turned on before - my BLTouch seems happier about this, with the M48 test giving me more consistent results than before.  I also turned WAIT_FOR_BED_HEATER on with it - a 5 x 5 auto bed leveling got even slower with waiting to reheat the bed every second probe or so.  Can't comment too much on the s-curve acceleration yet.  It sounds good during accelerations but I'll need more time for sample prints.  I turned on adaptive step smoothing too, again no comment so far.  And linear advance is enabled, with the default K-factor in code set to 0 (off).  I ran a few quick passes of the linear advance calibration and it looks like K=1.05 is giving the best calibration line, so printing right now is a benchie with everything except linear-advance (to compare to 1.1.8 benchies checking if s-curve and step smoothing do anything), and next will be a K=1.05 benchy.

    Out of curiosity, for anyone else playing with linear-advance on the A5, what kind of K values are you finding give the best results.  Like print temperatures - I expect some variation between people, but to all be in a somewhat similar range for a given material.
    Thanked by 1Samuel Pinches
  • itisnot_meitisnot_me 🌟 Super Member 🌟 Posts: 82
    Btw i just wanted to say that when i upgraded the firm ware i accidentally used this beta. My first test print came out horrible. Warping and curling on the bed. After i realized i used the beta i upgraded the firmware to the stable one and used the same print settings and it worked great. 

    I have the test print and can provide a picture if needed.
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    edited October 2018
    Hmm that is interesting! I would definitely be interested in both a photo and more details - e.g. stl, settings , gcode, etc. Thank you for the feedback.
    Post edited by Samuel Pinches on
  • itisnot_meitisnot_me 🌟 Super Member 🌟 Posts: 82
    For the attached file. Default settings on cura. I believe .3mm stock settings, besides maybe 200 nozzle and 60 bed. The only thing different from the side by sides is the firmware. Cura never did close on the model. 

    Thanked by 1Samuel Pinches
    zip
    zip
    MINI_All_In_One_3D_printer_test.zip
    1M
  • lacedemlacedem Member Posts: 1
    Hi,
    Just a little question, is that possible to be sure the updated was fine after the update. The new version uploaded correctly to the board, but as when I passed the commands “M502” then “M500" I had no return, I'm wondering is everything was fine.

    So is there a was to be sure that I'm running the  A5 Firmware 1.1.9C???
    Regards.

  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    edited October 2018
    Welcome @lacedem ,
    If you're using the Arduino serial monitor, make sure you have set your line ending correctly. I recommend using pronterface, you will see the version printed to the console when you connect to the printer.
    Thanked by 1lacedem
    Post edited by Samuel Pinches on
  • woszuwoszu Member Posts: 21
    edited November 2018
    Hi.
    If I install this 1.1.9 firmware, then i loose IR probe mod, from Steve Wagg (1.1.8c)??
    Post edited by woszu on
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    edited November 2018
    Yes you will. You will need to compare the two configuration files (configuration.h) and copy across the relevant settings. 
    Post edited by Samuel Pinches on
  • woszuwoszu Member Posts: 21
    Thanks Sam.
    Changes will only be in the file configuration.h?

  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    I think so. (95% sure).

    If there were any other changes required they would likely be in configuration_adv.h and pins_RAMPS.h
  • SilkroadSilkroad Member Posts: 2
    G'day all

    I recently flashed this v1.1.9C BETA on my JGAurora A5. I only customized the firmware along this howto https://jgaurorawiki.com/a5/silent-stepper-driver-tmc2208, as I do have the Watterott TMC2208 on the X and Y axis installed.

    Unfortunately I now suffer from unconditional stops telling me "wait for user" and the display (LCD community firmware 030718vB) asks for confirmation. Altough the confirmations does not effect the print and just stops anyway. Plus prints actually are terminated, as there is nothing I can do to resume them. So this results in a lot of garbage PLA I'm producing lately, while I rather have no idea why this happens in first place.

    Any clues what I'm missing here? Suggestions?

    Thank you.

    Regards
    Silkroad

  • SilkroadSilkroad Member Posts: 2
    edited November 2018
    Hey ya...

    This was kind of annoying, so I reverted back to stock firmware of January 2018. That's where the mentioned issues just vanished. Still kind of unpleased with the outcome of this latest Marlin firmware, I thought about to give it a second try and flashed the same Marlin (JGAurora A5 branch) v1.1.9 BETA (with the same TMC2208 alterations than before) again: Now it just works.

    So I still have no clue what went wrong on the first encounter, but firmware now behaves like it ought to.

    Thanks.

    Regards
    Silkroad
    Post edited by Silkroad on
  • Marco SalvettiMarco Salvetti Member Posts: 6
    Hi Samuel Pinches
    i own an A3S printer  and looking at the differences between the  1.1.8 firmwares for A5 and A3S I'm wondering if to flash the 1.1.9c  version on A3S need only the small changes in the Configuration.h.
    Or  even more generally i'd like to know if to keep the firmware up to date with GitHub progresses, it only need just that small modification to the config file or if there is something elese to modify.

    Tnx in advance.
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    Hi Marco, yes, the A5 and A3S are identical electrically as far as the configuration goes. The only changes that need to be made are to the printer dimensions, but you can also put more aggressive acceleration settings for the bed on the A3S because of the lighter weight. I hope that helps. I'm sorry - I've been too busy to keep up to date, so I have not finished tuning the 1.1.9C firmware sufficiently to recommend it. I would be interested to hear how you go.
  • Marco SalvettiMarco Salvetti Member Posts: 6
    edited December 2018
    Hi Samuel, yesterday I adapted your mods to the configuration.h to make it work for A3S.
    I flashed it successfully and now I need to test it. I just printed the benchy boat and didn't look bad but I need to do better tests.
    Anyway here is the 1.1.9c firmware for A3S:
    https://drive.google.com/open?id=13VSWpwlPzmcRwxKUeuhaAMWmkqxKpBYP
    Thanked by 1Samuel Pinches
    Post edited by Marco Salvetti on
  • AndreSchrammAndreSchramm Member Posts: 2
    Hello guys.
    Is anyone using Marlin 1.1.9 with the s-curve acceleration ? Could you describe the improvements?
    Thank you!
  • cs2000cs2000 🌟 Super Member 🌟 Posts: 51
    I assume this 1.1.9 firmware is still in Beta? I flashed 1.1.8 on my A5 when it arrived as i wasnt clear on what was reccomended
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    1.18C is still recommended. No improvement in print quality was seen, and too much has changed in 1.1.9 for the TMC crowd, that it will make all the instructions floating around invalid. Its one of the lower things on my priority list at the moment, but anyone else is of course welcome to have a crack at tweaking it.
  • Kenny_f_PowersKenny_f_Powers Member Posts: 2
    edited March 9
    Hallo,

    I love you for doing that great job but:

    just for my understanding,
    don't you think that the acceleration and travelling speeds are a little bit fast even in 1.18. maybe you are thinking something when you do that speed's.
    But for me personally is it a way too fast so i merge the acceleration/max Speed and so on from the original JG aurora firmware from their web page with your firmware. 

    Because i was thinking that some day my Y axis smash the endstop Out of printer.

    Thanked by 1Samuel Pinches
    Post edited by Kenny_f_Powers on
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    edited March 9

    I think the original homing speeds were too slow. I turned the max speeds up, and I turned the homing speeds up, but I think I turned down the acceleration? I can't remember exactly what we did in 1.1.8C, it was a long time ago now.
    I noticed an improvement in the print quality with 1.1.8C, and a quieter print as well (due to reduced acceleration). I originally had the homing speeds even faster, but we turned them down with 1.1.8B.  Some people asked for slower Z axis speed too, so we turned that down a bit too.
    But no-one has had any problems since then, so I think the endstop should be OK. 
    Also, with the original firmware the homing process is all one speed. With 1.1.8C, even though the first move is fast, the second homing move is much slower, for precision.  But, the good thing is that it is open source, so you can change it if you would like. :smile: 
    I have not had time to work on 1.1.9, but I will keep in mind slower homing speeds as a good suggestion.
    Thanks for your suggestion.
    Post edited by Samuel Pinches on
  • Der_MuckDer_Muck 🌟 Super Member 🌟 Posts: 238
    I agree, the printer can handle that without any problem.
    Buuut I was wondering why the retract settings doesnt effect anything. Today I found out that the max. feedrate on E is 25mm/s I set it now to 50, looks better now :D and I set it up to 250 in the SP3D and was wondering why the test prints looks every time the same LUL
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    Hehe... you're not the first to have that problem :wink: sorry!
  • Laser8302Laser8302 Member Posts: 30
    Did you take the file down?

    I'm installing TMC2208's in my printer and wanted to try 1.1.9C, but if 1.1.8C will work I'll just modify that firmware to work with my printer.

    Also installing a BL touch, and some LEDs/stepper driver cooling.
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
Sign In or Register to comment.