β€Ί β€Ί

JGAURORA JGMaker Magic Promotion


NEW Budget 3D Printer: JGMaker Magic
The best deal at the moment is from Gearbest, who are running a flash sale for just $179!
Amazon USA also is offering an $30 instant discount coupon on the JGAurora Magic - a great option for those who want it even faster!

JGAURORA A5S Deals


[6th Jun 19] The LATEST JGAurora A5S is already for sale under $400 - use coupon GBA5S11 for a further $15 off!
Print quality is better than A5 out of the box, and it only takes 10 minutes to assemble.
Click here to check out this deal!

A5s Z-axis problem

Hello,
i'm new in the 3D-Printer-World :)

Since yesterday I am owner of a Aurora A5s. The assembly was easy.

As a next step, I wanted to level the bed. So first home button pressed, the printer drives well to the home position in all axes.
I noticed that the Nozzle was way too high above the bed. So far I could not screw up the bed at all.
So I decided to move the endstop down. Since then, the Z-axis only moves up and no longer down. When I press the Home button the printer drives to the right x- and y-Home-Position. The z-axis drives only a bit up and that's it.
When moving the axes manually with the Move-buttons on the Display I can move all axes, except for the Z-axis, which does not respond when I press the arrow down, but it works upwards.

Can someone help me please? Is the endstop broken?

Holger

Comments

  • aestremsaestrems Posts: 29Member
    Hi Holger,

    Maybe you already watched, If not here two instructive videos for bed levelling A5

    Firs steps:
    Mesh levelling: 

    Did you try to move the Z to his highest position and try to move down? If it's moving down from the top maybe the problem is the endstop is to high in his position. 
  • jelot_itjelot_it Posts: 25Member, 🌟 Super Member 🌟
    Hi, sorry for my bad english.

    I have the same problem on the Z axis. Have you solved @hooger76 ?

    I have sent the M119 Gcode command to the printer and I've seen that the Z response is always "triggered", with or without the Z endstops pressed.

    So, I think the problem could be one of the following:

    1) a fault Z endstop switch
    2) a firmware bug/problem
    3) a fault on the controller board

    Do you think there can be other causes?

    With the M119 command I've this response:

    X has a status of "open" when the switch is pressed and a status of "triggered" when the switch is not pressed
    Y has a status of "triggered" when the switch is pressed and a status of "open" when the switch is not pressed
    Z has a status of "triggered" in both cases

    someone with a working A5S could try the M119 command and see what answers it gets?

    I opened a ticket to gearbest to figure out what to do, so for now I can not open the printer to do other tests ...

    someone who has already opened it, could tell me what kind of endstops are used?

    1) All NO
    2) All NC
    3) Mixed NO and NC

    tanks
  • jelot_itjelot_it Posts: 25Member, 🌟 Super Member 🌟
    The gearbest support told me to check the connection of the Z axis motors and the connection of the socket on the right side of the printer. If all is ok, told me to check the connection inside the printer.

    The connections are all ok.

    With the access to the control board I have made other tests...

    The endswitch are all NO and in a working state.

    I have switched the Z<->Y motors connections and the Z axis now works well, but the Y axis now don't works on Y-... so the Z motors are OK

    With a multimeter I have checked the continuity on the Z endstop socket and... is always "closed", so... the Z endswitch is "bypassed"

    So, seems to me that I have a control board with a short circuit on the Z endstop line.

    I await a new response from the gearbest support.

    Here are some photos. (Green socket are the Z axis, Blue socket are the Y axis)

    Z endstop not pressed:


    Z endstop pressed:


    Y endstop not pressed:


    Y endstop pressed:


    ZY motor socket in original position:


    ZY motor socket in "swapped" position:


    Z endstop socket (contitnuity check):


    Y endstop socket (contitnuity check):

  • Richy_TRichy_T Posts: 85🌟 Super Member 🌟
    edited January 28
    I had something similar. I moved the Z-axis to the extruder on the motherboard to test and it worked OK. When I moved it back, my Z-axis was working again and has been since.

    The thing is, the Z-axis connector was initially well seated so I am not completely confident that the issue is properly resolved. My feeling was that there may have been a poor solder connection on the driver chip (and may still be) and my moving things around merely flexed the board a bit. I guess I'll wait to see if the problem resurfaces.

    If you're sure it's the Z-endstop though, that's completely different.
    Post edited by Richy_T on
  • jelot_itjelot_it Posts: 25Member, 🌟 Super Member 🌟
    Hi @Richy_T, yes... I think we have different problems

    The gearbest support has confirmed to me that I have a broken control board and they will send me a new one (but the shipping times I guess will not be short). I will not have to send my board back, so I'm going to try to fix it.

    After a visual check, the circuit seems to me done this way:


    a kind of "switch debouncing"

    My problem should be that the C72 capacitor does not charge. As a further check, I measured the voltage at (point) 1 for the endswitch Y and Z with and without a pressed switch

    Y endstop voltage when pressed:


    Y endstop voltage when not pressed:


    Z endstop voltage when pressed:


    Z endstop voltage when not pressed:


    Seems confirmed that I have a broken capacitor.
    Does anyone know the specifications of the C72 capacitor?

    If I can I would like to avoid using one of the X+/Y+/Z+ capacitors as a donor...

  • Richy_TRichy_T Posts: 85🌟 Super Member 🌟
    These things tend to be fairly flexible. Have you tried an in-circuit measurement of one of the other ones?
  • jelot_itjelot_it Posts: 25Member, 🌟 Super Member 🌟
    No... my multimeter can not measure capacitor capacitance. I'm thinking of taking a new one for the measurement of smd components (with the possibility to measure also the capacity)
  • jelot_itjelot_it Posts: 25Member, 🌟 Super Member 🌟
    edited March 2
    Unfortunately the problem is not the C72 capacitor :(

    I have unsoldered in order:
    • the C72 capacitor
    • the J27 socket
    • the R162 resistor
    and the pins 1 & 2 of the socket are always in continuity.
    The tracks look good, so it should be the STM32 microcontroller :'(


    Post edited by jelot_it on
Sign In or Register to comment.