JGAURORA JGMaker Magic Promotion


NEW Budget 3D Printer: JGMaker Magic
The best deal at the moment is from Gearbest, who are running a flash sale for just $179!
Amazon USA also is offering an $30 instant discount coupon on the JGAurora Magic - a great option for those who want it even faster!

JGAURORA A5S Deals


[6th Jun 19] The LATEST JGAurora A5S is already for sale under $400 - use coupon GBA5S11 for a further $15 off!
Print quality is better than A5 out of the box, and it only takes 10 minutes to assemble.
Click here to check out this deal!

A5 Y-axis problem after reassembly

Hello.

One of the A5 printers that I have worked fine for about two months flat and then developed a problem with the prints not sticking to the bed. I could not get the printer to level properly, I have several JG Aurora printers, so there seemed something off with this one. I re-leveled the bar with the extruder, the bed isn't warped but the left side was always a fraction lower than the right. I noticed that there was significant play on the left side, so I decided to take the printer apart. I discovered that the chain was partially disconnected from the piece that was screwed to the Y-axis and this was causing one side to be pushed up a few mm. I tightened some of the screws that were loose, and fixed the chain. 

After reassembling it, everything worked fine except that the printer seems to be ignoring the Y-endstop, Most of the problems I've had with the JG Aurora A5 printers have been from them assembled wrong at the factory. I noticed that the x-axis seems to be the opposite from the direction the LCD arrows are pointing. When I hit the home button the thing seems like its very confused (like the axis is reversed from what its expecting), it sends the Y-axis to the back instead of the front for home). I've checked the cables (multiple times) against the youtube videos and the images on here. Seems correct, so I'm wondering if the factory firmware needs some kind of reset or if the printer was cabled up backwards or something?

At this point, I'm thinking I want to get the thing cabled up right and then just flash it with the community firmware.

Any suggestions / help would be appreciated :)

Thanks

Comments

  • Samuel PinchesSamuel Pinches Posts: 2,106Administrator
    edited December 2018
    Welcome @John Buswell !
    The y-endstop is at the back of the printer, near the y motor, so the bed moving to the back is correct when homing. The front left corner is the (0,0) coordinate position, which happens when the bed is fully back. Does that make sense or am I perhaps misunderstanding something about your question?
    Cheers,
    Sam
    Post edited by Samuel Pinches on
  • John BuswellJohn Buswell Posts: 5Member
    Sorry if it wasn't clear. The bed is going to the back but it tries to keep going (makes a fairly loud banging noise when it hits the end for a few seconds before stopping). Like its not registering the information from the y endstop?
  • Samuel PinchesSamuel Pinches Posts: 2,106Administrator
    edited December 2018
    Ok, I get it.

    1. plug printer into computer
    2. download and install pronterface
    3. connect to printer
    4. send command "M119"
    5. Pronterface should show that all endstops are "open"
    6. Move y-axis to end of travel, so that endstop is pressed
    7. send command "M119"
    8. should see "triggered" for y-axis. If you don't then you need to check the endstop wiring for the y-axis.
    Post edited by Samuel Pinches on
  • John BuswellJohn Buswell Posts: 5Member
    Cool thanks. I'll go give that a try :)
  • Onikami82Onikami82 Posts: 1Member
    i just replace the y axis timing belt on my printer and get stuck at point and lock up at the half way how do i fix that problem on my printer please write soon as you can.
    thank you 
  • Samuel PinchesSamuel Pinches Posts: 2,106Administrator
    Welcome @Onikami82
    I'm sorry, but without more details we probably cannot help. Can you see where it is getting stuck?  You will probably need to open up the chassis again and inspect the y axis.

    If the bearing rails are not parallel, you will also have a problem with the movement, you may want to check that too.
    Best,
    Sam
  • John BuswellJohn Buswell Posts: 5Member
    @Samuel Pinches Thanks for your help on this. The y-axis was displaying "triggered" correctly but was still doing its weird behavior. Unfortunately we've been quite busy here, so this A5 got set aside as we opted to purchase A1 / A1x models and the CR-10 S / CR-10 S5 for our projects. We had some problems with a new A1 (bad touch screen) that was supposed to expand our capacity at the lab, so I decided to revisit this A5 to see if I could fix the problem.

    Turns out the y-axis end-stop was always in triggered, the wiring is labeled and everything looked correct. I messed about with the end-stop and multi-meter, but it seemed to be ok. So I looked up some photos and watched a few videos on disassembling the A5 (our other A5s are all active in production, so didn't really want to take one of those off-line to open it). I noticed the cable on ours for the filament run-out detection was different.

    Upon closer inspection I discovered that:

    1. Filament run-out wire was plugged into the y-axis endpoint on the board (but was labeled y-axis endpoint)
    2. y-axis endstop was plugged into the filament sensor pins on the front panel, but were labeled B1
    3. The z-axis wire was plugged into the wrong connector on the board (the x,y,z have a second connector between where they are plugged in and the longer black connector on the board)

    Swapping the y-axis end stop and the filament run-out, and plugging the z-axis cable into the other z-axis connector, immediately fixed the problems. Pronterface showed everything was good, and the home / move buttons on the printer now correctly corresponded to what the printer was actually doing.

    This isn't the first time we've had weird assembly issues with JG Aurora printers, one of our recent A1X printers had the ribbon cable between the front panel and the main board unplugged. We've had an A5 with the track disconnected for the y-axis, and I've had to either replace screws or "tweak" the filament feeder mechanisms on all of our A1/A1X printers. On both A5's we also had to readjust the gantry (that says 3D-Printer) because it was slightly skewed. These aren't big deals, considering the cost of the printers compared to other options.

    That said, once they are level and going, these things are extremely reliable. We've been printing pretty much 24x7 for over a year, with very few issues.

    Hope the above info helps some folks. Thanks again for your help!
    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Posts: 2,106Administrator
    What a load of garbage... they are supposed to test this stuff!!! :unamused:
    Glad you had the patience to sort it, nice job :wink:

Sign In or Register to comment.