[20th Mar 2018] Take $10 off any $200 or more JGAURORA purchase on Gearbest! Use coupon GBLIVE31902 , and click here.

[4th Dec 18] JGAurora A5 Euro buyers: A5 in stock in Gearbest Europe shipping from Czech Republic.

Use coupon GBJKA5 to bring the price under $280, and click here to buy!



Also available from their Spain warehouse - buy here.
[6th Nov 18] The NEW recently released JGAurora A5S is already for sale under $400! Print quality is better than A5 out of the box.
Click here to check out this deal!

Problem with a5s bed clean

edoardo11edoardo11 Member Posts: 4
Hi everyone,
I have the jgaurora a5s about 15 days, and it's my first printer.
I made the first prints, to try, using the blue ribbon already pre-applied. Then I removed it, at the beginning the prints did not stick so I made the mistake of spraying some hair spray. After 2 prints I realized what had happened (I attach a photo). Now I can not clean it anymore. I tried to leave it to soak with hot water and alcohol, clean it with only alcohol and even with dishwashing detergent. What can I do? what happened to you?
Post edited by edoardo11 on

Comments

  • Richy_TRichy_T 🌟 Super Member 🌟 Posts: 77
    Ouch  :'( those aren't cheap to replace either. I think I would go with one of those magnetic beds as a replacement. I find the adhesion isn't quite as good as I'd like in any case.
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,441
    edited February 1
    Welcome @edoardo11 ;
    Does the bed adhesion still work? http://jgaurorawiki.com/a5/bed-adhesion


    Post edited by Samuel Pinches on
  • HobietackerHobietacker Member Posts: 3
    I had the same problem. I printed with the tape on it and sprayed Agua net hair spray on it. And it worked until an oblect stuck to it and would not come off. I ended up using a razor blade to get it and the tape off. The glass is really all you need . Things stick well and op right off.. I have the stains too. I will keep trying .
    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,441
    Welcome @Hobietacker - it is really great when it works :smiley:, worth the effort to learn!
  • HobietackerHobietacker Member Posts: 3
    how do you post pictures

  • Samuel PinchesSamuel Pinches Administrator Posts: 1,441
    edited March 9
    @Hobietacker
    You can drag photos into the text box area, or can click the upload photo button in the toolbar:

    Post edited by Samuel Pinches on
Sign In or Register to comment.