Small milestone - we passed 300,000 pageviews on the forum today (16th Sept)! 😁 P.S if you are not aware we're running a competition in the facebook group. Head over here to enter, if you haven't already! Ends Sun 22nd Sept!

JGAURORA JGMaker Magic Promotion


NEW Budget 3D Printer: JGMaker Magic
The best deal at the moment is from Gearbest, who are running a flash sale for just $179!
Amazon USA also is offering an $30 instant discount coupon on the JGAurora Magic - a great option for those who want it even faster!

JGAURORA A5S Deals


[6th Jun 19] The LATEST JGAurora A5S is already for sale under $400 - use coupon GBA5S11 for a further $15 off!
Print quality is better than A5 out of the box, and it only takes 10 minutes to assemble.
Click here to check out this deal!

Z Axis deceleration

Hi there. Would anybody be able to show me where to decrease acceleration in the marlin firmware for the Z axis? Having motor skipping steps due to to much acceleration after upgrade to direct drive but i cant find the correct line in firmware 
 I ONLY want to decrease acceleration for Z axis alone, not X, Y as well 
 Thanks...!

Comments

  • Samuel PinchesSamuel Pinches Posts: 2,060Administrator
    Welcome @Devon Ghyu !

    Have a look in the configuration.h file, lines 561 to 567.

    /**
     * Default Max Acceleration (change/s) change = mm/s
     * (Maximum start speed for accelerated moves)
     * Override with M201
     *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
     */
    #define DEFAULT_MAX_ACCELERATION      { 1000, 500, 100, 5000 }
    

    The maximum acceleration for the Z axis is the third number in that set, 100.

    You may also need to increase your Z stepper driver current. Info on the wiki how to do that here.

    Cheers,
    Sam

  • Samuel PinchesSamuel Pinches Posts: 2,060Administrator
    edited January 19
    You can also override the set acceleration value with M201 for testing different rates. You can send manual gcode commands using pronterface.
    Post edited by Samuel Pinches on
  • philwald1184philwald1184 Posts: 28🌟 Super Member 🌟
    Thanks for the reply Samuel .I will try decreasing acceleration first...
  • Devon GhyuDevon Ghyu Posts: 4Member
    Ok I tried lowering th acceleration and that really didn’t help. That M201 command is only for starting acceleration. I need to lower just the z axis travel speed with a command like M205. But that command also lowers XY any way to lower travel for z alone? Any help would be appreciated. Thanks! Ps, I did try lowering Z with M203 and M204 but neither did anything
  • Samuel PinchesSamuel Pinches Posts: 2,060Administrator
    You could flash the custom firmware - in the configuration.h file you can also change the max speeds and accelerations for all of the axis individually. (see my previous post for the section you need to look at)
  • Devon GhyuDevon Ghyu Posts: 4Member
    Thanks for the reply. I have been using custom firmware for a year now. But looking at the firmware there doesn't seem to be an independent option to adjust z speed.
     I have tried lowering max feed rate with M203 on the z and it didn't help,
     I've tried lowering the max acceleration start speed with M201 but that only adjusted the start speed and still made motor skip when it got to full speed 
     Only option I've found to work for me is lowering the travel acceleration with M204 T but that made the X and Y too slow.
    Can you please show me where to lower it independently from the others?
    I do realize I might be dealing with a faulty stepper motor and am in the process of looking for one. 
    My drivers are adjusted and can not imagine what else it could be. But whenever I home printer, or move it up 10mm or even when starting prints, the left motor will skip a bunch of steps while its trying to move unless I help it along. No problems at all while printing ....
  • Devon GhyuDevon Ghyu Posts: 4Member
    Never mind. I figured it out. It is the max feedrate setting after all. I must not have saved it correctly with prontorface the first time. All good. Got it slowed down now. Thanks!
Sign In or Register to comment.