JGAURORA JGMaker Magic Promotion


NEW Budget 3D Printer: JGMaker Magic
The best deal at the moment is from Gearbest, who are running a flash sale for just $179!
Amazon USA also is offering an $30 instant discount coupon on the JGAurora Magic - a great option for those who want it even faster!

JGAURORA A5S Deals


[6th Jun 19] The LATEST JGAurora A5S is already for sale under $400 - use coupon GBA5S11 for a further $15 off!
Print quality is better than A5 out of the box, and it only takes 10 minutes to assemble.
Click here to check out this deal!

E Steps Calibrating Issues

Hey guys,

Tom here! First of all I wanted to thank you for this awsome platform!

Well I recently bought an A5S and was actually quite happy with it. But 3 days ago I wanted to make my prints more accurate an decided to calibrate the E Steps. What meanwhile drives me nuts. Before I just got massive overextrusion but now I cant figure it out at all. 

At first I was confident with what I did to the e steps so I started to experiament what flow I need. But suddenly I started to get underextrusion. When I then checked the e steps again there was another value than I did save earlier.

First I got Pronterface, but I could only extrude when I hit the Extrude Button! When I type G1 E100 F100 the extruder Motor runs backwards or way too much foward.

Then I downloaded Repetier host and it all looked as it would work but when I save the new e steps value an then disconnect the laptop and switch the printer off and on again It still has the "old/wrong" e steps value.

Now I tried again with Pronterface but it just wont work.....especially as I type in the commands directly. Right now it pushed something like 30cm of Filament backwards after I typed in G1 E100 F100. And the next thing is when I let it extrude 3 times 100mm I get 3 times different results! I don't even know how this is possible!! And the extruder is not skipping steps!!! Not now at least.....been through 2 clogged nozzels yesterday.

I use M503 to get the actual e Steps
M92 E..... for the new and M500 to save them.

Does anyone have a idea? Or am I just too stupid??

Thanks in advance!!!!

Cheers Tom
Thanked by 1Samuel Pinches

Comments

  • Samuel PinchesSamuel Pinches Posts: 1,983Administrator
    @tomtom - welcome :smiley: 
    Make sure you have put your printer into relative extrusion mode before manually moving. http://marlinfw.org/docs/gcode/G091.html

    You will also need to install the custom firmware for the M500 to be accepted.

    Cheers,
    Sam



  • aestremsaestrems Posts: 29Member
    @Samuel Pinches @tomtom has the A5S so no custom firmware for this machine maybe this is the reason why is not saving correctly in the machine, isn't it?
    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Posts: 1,983Administrator
    Oh ... Doh! I didn't read carefully enough. Yes - I don't think the A5S is calibrate-able (if that is a word).
    Thanks @aestrems ;

  • Samuel PinchesSamuel Pinches Posts: 1,983Administrator
    You may be able to set the steps per mm manually by adding commands to your slicer start gcode, but I am pretty sure the EEPROM saving is disabled.
  • tomtomtomtom Posts: 3Member
    Hey guys thanks a lot for your answers!!!

    As I found outthat I can set a new value but after switching the Printer off its set back to the old one!! 

    So basically the last 4 days where pretty senseless as I tried to calibrate an uncalibrate-able firmware!? *damn*

    But at least I could not set anything completely wrong!! ;)

    You mean I should try to add M92 E.... in the slicer start gcode? 

    I'll give it a try!

    Another thing.....is it possible to change the tension of the extruder Motor towards the Filament? I can't find anything for the A5S (A5). The printer started to skip steps as I changed to Petg. Or can it be that the 245°C are not hot enough? The filament is ratet from 230-250°. But I already got a fair amount of stringing so I guess it should be hot enough?!

  • aestremsaestrems Posts: 29Member
    Let us know if work with the M92 E... in the start of the gcode, maybe i will try too.

    Is your extruder motor skipping steps with PLA? If not I will increase the temperature, just be carefull the PTFE tube can melt form 250°C
  • tomtomtomtom Posts: 3Member
    Alright guys it seems that it is working as I did put M92 E..... in the start gcode!!! Thanks @Samuel Pinches !!!!

    As I start the printer via Repetier it says E202, but when the print strarting (with the new start gcode) it says the value I put in the start gcode!!! Finally its going in the right direction!!!!  :+1:

    I'm gonna try to calibrate it again in the evening!! Just wanted to know if its working and let you guys know!!! 

    cheers
  • Samuel PinchesSamuel Pinches Posts: 1,983Administrator
    Awesome, thanks for the update @tomtom !
  • aestremsaestrems Posts: 29Member
    @tomtom Great!! I will give a try too 
  • SomeoneYouLikeSomeoneYouLike Posts: 38Member
    Where in the start GCODE did you put it? Or does it even matter and I can put in anywhere in the text? @tomtom

Sign In or Register to comment.