[4th Dec 18] JGAurora A5 Euro buyers: A5 in stock in Gearbest Europe shipping from Czech Republic.

Use coupon GBJKA5 to bring the price under $280, and click here to buy!



Also available from their Spain warehouse - buy here.
[6th Nov 18] The NEW recently released JGAurora A5S is already for sale under $400! Print quality is better than A5 out of the box.
Click here to check out this deal!

Pause at z layer

I’m try to pause at z layer or z height to change filament. I have added the script in cura, sliced it and then loaded the gcode into octoprint for printing but it does not pause, it prints right past the layer or height I request. What am I doing wrong? I’m using cura 3.6. Thanks in advance.

Comments

  • Richy_TRichy_T Posts: 71🌟 Super Member 🌟
    Octoprint sends codes directly to the printer so I think this is an Octoprint issue.

    Do you know which code it's using? If it's M600, it might be sending it directly through but I think our printers don't understand this and would need something based around the M0 code. However, it would probably be better for Octoprint to handle it all so it might be worth looking there.
  • Richy_TRichy_T Posts: 71🌟 Super Member 🌟
    I'm going to try what OutsoucedGuru suggests here https://discourse.octoprint.org/t/pause-at-layer-end/1412/12

    The main issue is that you have to know the extruder setting. From what I've seen, that should be retrievable in Octoprint scripts though (maybe). Or if it's inserted in the script directly, you'd have to get it from the previous extrusion instruction.


  • Samuel PinchesSamuel Pinches Posts: 1,235Administrator
    Don't forget there is a buffer of commands saved on the motherboard - when you push pause in octoprint, octoprint will stop sending new print data, but depending on the complexity of the layer, and the print speed, it can take up to 1 minute for the print to stop since there is still a buffer of commands already sent to the motherboard.

    What you can do is insert the pause command into the print file gcode itself, so that you will get the exact pause position you want.

  • rhaub101rhaub101 Posts: 39Member
    That probably explains why the small 10 layer test print didn’t pause at layer 5. How do I insert a pause command in the gcode, move the head, and the resume after the filament change?
  • Samuel PinchesSamuel Pinches Posts: 1,235Administrator
    1. Open the gcode file
    2. look for a layer change (G0 or G1 are move commands, find one with a Z move indicated)
    3. insert pause command on a new line (I don't know if this is M600 or M0... trial and error)
    4. Optionally, you can insert other commands to move out of the way too, like here.
    5. Resume printing when ready via Octoprint or Pronterface.
    Useful links:



Sign In or Register to comment.