NEW Budget 3D Printer: JGMaker Magic - here's the best deals at the moment:
- Gearbest: Flash sale for $189
- Banggood Store: Take off $20 with coupon bd5cc5
- Amazon USA - $30 instant discount coupon
[6th Nov 18] The NEW recently released JGAurora A5S is already for sale under $400! Print quality is better than A5 out of the box.
Click here to check out this deal!

Just got my A5S, and can't get it working.

After failing to get the bed leveled to my satisfaction I watched a video that said I should preheat the bed to do a proper level. So I went to the temperature menu and it just flashes "EXTU1 Sensor Error". Should I pack this up and ship it back to Amazon, or is this an easy fix?

Comments

  • SomeoneYouLikeSomeoneYouLike Member Posts: 24
    Check your power connectors. I had the same issue, after triple checking my wires, I realized that one wire was the wrong way. After I made sure the power connectors on the side of the printer was connected properly, I restarted the printer and it worked fine after that. 
    Thanked by 1Samuel Pinches
  • milquetoastmilquetoast Member Posts: 3
    Checked and quadruple checked, everything is seated properly as best I can tell, no obvious damage to anything either.
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,623
    edited March 6
    It could also be a loose connector inside - you could email JGAurora for help (support@zgew3d.com). I expect if you mention that you are about to return it back to Amazon you will get very prompt help.

    Post edited by Samuel Pinches on
  • milquetoastmilquetoast Member Posts: 3
    Thank you, I will do just that.
Sign In or Register to comment.