[20th Mar 2018] Take $10 off any $200 or more JGAURORA purchase on Gearbest! Use coupon GBLIVE31902 , and click here.

[4th Dec 18] JGAurora A5 Euro buyers: A5 in stock in Gearbest Europe shipping from Czech Republic.

Use coupon GBJKA5 to bring the price under $280, and click here to buy!



Also available from their Spain warehouse - buy here.
[6th Nov 18] The NEW recently released JGAurora A5S is already for sale under $400! Print quality is better than A5 out of the box.
Click here to check out this deal!

Filament sensor problem

Hello everybody,
My JG Aurora A5 was bought Oct 2018.
After several prints and approx 1.5 kg of filament I had problems with interruptions of prints, beeping and finally my A5 was not able to print as there were no files found on the USB. That led me to Da Hai's video and I tried to reverse the filament sensor plug as instructed. While removing unfortunately I destroyed the mks tft board as glue was not removed completely and so I pulled off the board pin connector including parts of board solder. No chance to repair.

I ordered a new board of which I received version 4.0 instead of 3.0. This was installed and printing is fine without the filament sensor plugged in. Unfortunately this function is lost at the moment.
If I connect filament sensor in any af the directions I receive the message "filament detection sensor is no pressed" when I start printing, independent of filament in or out.
Only exception: if plug put in original orientation  (red wire in upper and black in middle) and no filament loaded, there is no message and printer would start.

I tried a new 3 pin filament sensor and same problems. When there is no filament in it starts printing, when feeding filament in it stops

Has anybody made similar experience? Any idea what will help. I also tried what AETEK proposed in the "how filament sensor works" post (install resistor between the outer 2 pins) but nothing changed.

Is there any experience with the version 4.0 tft board? This has little different layout and I am not sure whether I have problem with my sensor or wiring or whether the board needs different wiring.

Thanks for your ideas

Krenex

Comments

  • Samuel PinchesSamuel Pinches Administrator Posts: 1,441
    Hi @krenex ,

    Sorry to hear you're still having problems with that MKS TFT28 filament sensor.

    On the 6 pin header, there is one side marked PB0, and one marked PB1, with + and - as well.

    V3.0 MKS TFT28 board





    From the PDF documentation, the pause trigger should occur when the B1 line is connected to either the + or - pin - , and the specific pin is set in the MKS firmware cfg file:

    From the manual:

    One end of MKS DET connects to the PB1, another end connects to the “-“ or “+” of the PB1.( If Low Level effective, it connects to “-“, if High Level effective, it connects “+”.) Choose the Low Level effective or High Level effective in the configuration.

    In the "mks_config.txt" file (from V3 MKS firmware)

    #set PB1 signal (high level:1; low level:0)
    >cfg_PB1_trigger_Level:0

    With Level set to 0, the S pin should connect with the "-" pin when the switch is triggered. With the Level set to 1, the S pin should connect with the "-" pin when the switch is triggered.

    NOTE: in older versions of the MKS firmware this setting was different:
    V1 to V2 firmware:
    #the level signal of outage detection module PB1(low level:0; high level:1)
    >cfg_PB0_PB1_Level:0


    Also, make sure that the function is not "shielded":

    #shield the function of detection filament (0:no shield ,1:shield)
    >cfg_disable_MT_det:0


    Hopefully that gives you some things to try?






  • Samuel PinchesSamuel Pinches Administrator Posts: 1,441
    edited March 9
    You should be able to check the active pins on the filament sensor connector with a multimeter, using continuity mode. There may be two pins that are connected when the sensor button is pressed (no = Normally Open contact, such that pressed button  = filament is present), and two pins that are connected when the sensor button is released (nc = Normally Connected, such that released button = no filament).

    Post edited by Samuel Pinches on
  • krenexkrenex Member Posts: 3
    Hello Samuel, 
    thanks for your answer and your support. 
    By the way: big thanks to you and Da Hai for all the videos and support. These enabled me executing many mods and troubleshooting. 

    I was afraid of making a firmware update to the MKS board as I have the 4.0 version, not sure whether it would work. But after reading your comments I just did it as my problem quite good fit to your explanation. 

    Firmware update worked and after this the problem was solved

    By the way: below you see a picture from the new board. Some more pins available but the B1 is still there
    Thanks again, Krenex


    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Administrator Posts: 1,441
    Excellent, so glad to hear it :smiley:
Sign In or Register to comment.