β€Ί β€Ί
Small milestone - we passed 300,000 pageviews on the forum today (16th Sept)! 😁 P.S if you are not aware we're running a competition in the facebook group. Head over here to enter, if you haven't already! Ends Sun 22nd Sept!

JGAURORA JGMaker Magic Promotion


NEW Budget 3D Printer: JGMaker Magic
The best deal at the moment is from Gearbest, who are running a flash sale for just $179!
Amazon USA also is offering an $30 instant discount coupon on the JGAurora Magic - a great option for those who want it even faster!

JGAURORA A5S Deals


[6th Jun 19] The LATEST JGAurora A5S is already for sale under $400 - use coupon GBA5S11 for a further $15 off!
Print quality is better than A5 out of the box, and it only takes 10 minutes to assemble.
Click here to check out this deal!

Z axis steppers grinding noise TMC2130

cs2000cs2000 Posts: 56🌟 Super Member 🌟

Hey all,

I installed the TMC2130 drivers a few weeks ago now, but had some printer downtime, so have really only been using them for a little bit.

I seem to have prints that after a certain amount of time begin to fail. I can hear the extruder motor begin to click, so I baby step the Z axis up a bit and its OK for a few layers, then it comes back again. I cant babysit the printer through a 20 hr print, adjusting the Z axis what seems like almost every layer!

So I thought tonight id raise the Z right to the top and measure the offset from the rails that the printhead moves on, to the top of the frame, and they were off by a 2.5mm from side to side. Ive actually done this numerous times over the last week thinking the grinding noise was basically the rails not being level. but it always keep going back to a few mm off after a print and I get the extruder skipping/clicking symptoms come back. Obviously this offset is then affecting my bed level and all sorts.

The only mod I have done in that area is upgraded to the TMC2130 steppers. I did set the Z Axis to 0.85V as detailed on the wiki, but am I right in thinking that its likely set too low? It only seems to grind right at the start and (possibly, but not 100%) end of a movement. If I move 10mm up, it grinds, moves perfectly and then stops as it should.

Do you agree this would likely be the cause, either a too low, or too high(?) stepper voltage, would both cases cause a grinding from the steppers? Im thinking it could be too low. When starting a movement obviously you need a lot more torque than to maintain the same movement, so it could be too low maybe? Just after some advice before I open it up (again) and tweak the voltages.

I have them cooled by a squirrel cage fan and a 3d printed fan duct, so im sure cooling is OK, just not sure where to go from here without reverting back to the noisy drivers that came with the machine!

I cant tell if its one of the other stepper, sounds like both in my opinion.

Comments

  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    Also, if it helps, the steppers themselves are always cold. My previous printers, these things get too hot to touch, so maybe they are indeed under-volted? I don't really understand how that 0.85v setting was figured out personally, so I could be waaay off the mark. But id expect if it was too much voltage, they would be hot.
  • Samuel PinchesSamuel Pinches Posts: 2,060Administrator
    0.85V probably is too low from what I've seen people use. If you find some good settings, feel free to update the wiki - I don't use TM2130 myself.
    Thanked by 1cs2000
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    Hmm, so I opened it up to tune the voltages and realised I didn’t even upgrade the Z steppers. I just did the X and Y.

    measured the voltage in the standard steppers and it measures at 0.83 volts, so I bumped it up to 0.93 instead.

    will see how this goes and if it’s still acting up il upgrade the Z to the tmc2130
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    edited April 6

    Well rather embarasingly, I figured it out. I accidentally touched the threaded rods and realised they weren't lubricated, they were sticky! The grinding noise was not the motors, but rather then rods rattling against their bearings/nuts/whatever guides them up the rods.

    I lubricated the rods with some grease and all seems OK now!

    After a while, I started to get inconsistencies again , but the first 90 mins went perfectly. I didn’t clean the lead screws at all and I’m just using heavy duty grease meant for farm machinery, so it’s not the right stuff, but it’s proved the point!

    Have ordered some machine oil to use and will remove and fully clean the lead screws with a solvent when it arrives., should fix it totally

    Thanked by 1Samuel Pinches
    Post edited by cs2000 on
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟

    Right, bit of a thread bump on this one. Still trying to actually fix this, (the "fix" above was short lived at best). I today finally installed a TMC2130 on that axis which didn't fix the issue, BUT it meant I could actually hear things better since the motors were quieter.

    Can someone take a look at this, and see what they think please?

    That noise is me moving the Z axis 1 mm at a time, it makes that weird grinding and erratic movements only for the first 2 mm, after that everything is fine, but this is meaning im getting terrible "levelling" results as the axis aren't moving properly :) It only affects the stepper motor on the right side of the printer.

    I have tried the following to fix it.

    As above, cleaned and re-lubed the lead screws (threaded rods) with PTFE grease.

    Flipped the lead screw upside down to see if that end was warped or something.

    Incresed the motor current from recommended values

    Moved the threaded coupler up a little in-case it was fouling on the stepper driver body.

    Im out of ideas. I wouldn't expect a machine that literally 3-4 months old to have a dead motor. But im not 100% sure its that. Im thinking of firing the parts cannon and ordering a new motor, new motor cable, new coupler, new lead screw and whatever the little brass bushing piece is that's on the gantry (that the threaded rod goes into) as I don't know what at fault here :(

  • Samuel PinchesSamuel Pinches Posts: 2,060Administrator
    @cs2000

    Is this with the community firmware or the factory firmware? If the issue occurs with one, can you please verify it occurs with the other as well? Cheers.
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    OK, tried flashing the latest stock firmware in your Dropbox. after a bit of fiddling I got it loaded, but the printer does the same thing, so that rules out firmware as the issue then
    Thanked by 1Samuel Pinches
  • Samuel PinchesSamuel Pinches Posts: 2,060Administrator
    Can you swap the port the motor is plugged into and see if the same behaviour occurs? You may want to swap the z endstop ports too to match.
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    edited May 2
    Thanks for the assistance. I’m now almost sure it’s the motor. 

    I unbolted it from the frame and noticed it’s super hard to turn with my hand. 

    When i I plugged it back in, I tried manually moving the couplers, the left side one is easy to move, the right side one takes quite a bit of force. So dead/dying motor, it has a lot more resistance than the other motor of the same type.

    il get in touch with jgaurora as I’d expect this to be a warranty item.

    the motor in question is a j-4218HB1401
    Post edited by cs2000 on
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    Update, JGAurora sending a motor via warranty. Because i wasn't sure, ive also ordered 2 replacement motors from eBay, feel like replacing both motors at the same time will lead to more consistent results.

    WIll update again once they arrive and hopefully fix my issue and i can finally enjoy this thing!
  • Samuel PinchesSamuel Pinches Posts: 2,060Administrator
     I’d also recommend if you’re changing out the Z axis motors, take the time to clean the JGaurora gunk off the lead screws, and replace the lubricant with a high-quality PTFE based lubricant 

     Pro tip: you can remove the lead screws using a drill to save time 
    Thanked by 1cs2000
  • Der_MuckDer_Muck Posts: 265🌟 Super Member 🌟
    Also here, try to change to better quality stepper motors, there are many stronger once. 

    1.5A 17HS4401S 1.8Β°

    Thanked by 1cs2000
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    Thanks @Samuel Pinches , I have previously done that anyway (i thought that was my initial issue), its very well coated in PTFE lube ;)

    @Der_Muck Thanks. Il see how the replacements go, and if i have any further issues, il go for the upgraded models :)

    The faulty motor has been stripped from my printer and has been sat on my workbench for about 4-5 days now. I tried turning the shaft yesterday and it was impossible to do by hand. Since its already broken, i attached my drill to it and gave it a spin, which had no issues of course, but just impossible to move by hand, the other one spins pretty easy, so 100% a dead stepper. In the bin it went.

    Hoping once this is replaced i can actually get something decent printed and FINALLY get the IR sensor working. I've been having horribly inconsistent results with it, but im pretty sure i know why now (bloody stepper!)
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟

    Right! So im waiting for the replacement stepper from JGaurora, but in the mean time I bought some steppers from ebay

    https://www.ebay.co.uk/itm/163002471299

    They were advertised exactly the same as others around the web and seemed a good replacement. Installed them, and got either nothing at all, or occasionally no movement just buzzing noises, not happy!! I Tried both turning up and turning down the voltage on the stepper driver, nothing made any difference. I did also test the standard stepper drivers, but again, no change in behaviour.

    The steppers came with some cables too, so I plugged a single stepper into the Z axis plug using the included motor cable, and It worked!

    I don't know if the wiring on these steppers are different to the JGAurora ones, or if I have damaged the standard wiring, but I ended up having to cut up the wires that came with the new steppers to make a Y harness so I can run both motors for the Z axis (like standard).

    I also had to set the voltage to more like 1.4v rather than 0.9 otherwise they would stall very easily.

    Anyway, running a test benchy boat print now and the issues I have been having looks resolved. I have plugged in the IR sensor board too and again, all seems good (for the first time ever...).

    Curious if I have damaged the standard Z axis wiring loom, or if these are wired different (I don't know if there is a standard pinout for stepper motors), but il tackle that another day. Just happy to be in a somewhat functional state again after seemingly months of on and off weird issues with this machine!

  • Der_MuckDer_Muck Posts: 265🌟 Super Member 🌟
    When the stepper only vibrates, the wireing is wrong, get always sure before pluging in any stuff. You can damage steppers with that wrong wireing.
    Thanked by 1cs2000
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    edited May 12

    Lets call it a newbie mistake, I assumes all stepper drivers, at least those aimed at 3d printers, were wired the same. As I say, using the cables that came in the box with the new steppers and making a Y cable out of them, all has gone really well.

    Been printing on and off almost continually since my other post, all seems SO much m ore stable and reliable now. Even been printing with ABS for the last 10 hrs, only had a single failure out of 10 parts I've printed so far, so looks good! Previously, I couldn't even get a single ABS part to stick, with ABS, the first layer is even more critical than with PLA which is very forgiving in comparison.

    I have tested the standard A5 Stepper wiring using continuity test on my multimeter, all checks out OK, so like you said, the wiring was just different, so that's something good :)

    Due to ABS needing a stable build area temperature, I have the bed at 104c (the printer seems to think the heater has failed when It reaches 105, I think there's a max bed temp in firmware somewhere that's probably tripping it), I actually have to shut the small bedroom door and keep it shut to get ABS to print reliably. After 12 hrs of ABS printing, its almost 40c in this room, im melting!!!!

    Post edited by cs2000 on
Sign In or Register to comment.