JGAURORA JGMaker Magic Promotion


NEW Budget 3D Printer: JGMaker Magic
The best deal at the moment is from Gearbest, who are running a flash sale for just $179!
Amazon USA also is offering an $30 instant discount coupon on the JGAurora Magic - a great option for those who want it even faster!

JGAURORA A5S Deals


[6th Jun 19] The LATEST JGAurora A5S is already for sale under $400 - use coupon GBA5S11 for a further $15 off!
Print quality is better than A5 out of the box, and it only takes 10 minutes to assemble.
Click here to check out this deal!

JGaurora A5 doesn't connect to PC anymore

Hello Everyone, 

I uploaded my firmware to the custom version succesfully. I noticed my hotend got off setpoint and got thermal runaway errors. so I wanted to connect my printer to my pc and do some PID tuning. However, I get the following error from pronterface;
connect_to_printer
  File "printrun\printcore.pyc", line 46, in inner
  File "printrun\printcore.pyc", line 197, in connect
  File "serial\serialwin32.pyc", line 31, in __init__
  File "serial\serialutil.pyc", line 261, in __init__
  File "serial\serialwin32.pyc", line 71, in open
  File "serial\serialwin32.pyc", line 186, in _reconfigurePort
"ValueError: Cannot configure port, some setting was wrong. Original message: [Error 31] A device attached to the system is not functioning."
 I also checked if i could still connect to the arduino IDE, the answer is no. So my PC is not being able to comunnicate with the main board. 

Does anyone know how to tackle this problem? I already put the factory LCD firmware back, which didn't fix the problem. 

thx!

Comments

  • Samuel PinchesSamuel Pinches Posts: 1,761Administrator
    edited May 24
    Please try restarting the PC, choosing the com port again, and the speed at 250000. Let me know if that fixes it.


    Post edited by Samuel Pinches on
  • Christiaan VeeningChristiaan Veening Posts: 5Member
    Hi @Samuel Pinches, thx for suggesting this forum (contacted you earlier on YouTube). I did restart my pc, but the error remains :( also tried different USB cable and port. 


  • Samuel PinchesSamuel Pinches Posts: 1,761Administrator
    edited May 24
    But the printer works perfectly otherwise via the LCD? Very odd. Hmmm...
    Post edited by Samuel Pinches on
  • Christiaan VeeningChristiaan Veening Posts: 5Member
    I will verify if it will start a print, but i guess so. despite the fact that the printers suffers from thermal runaway, would not imply I won't be able to connect is to my pc, right?. Very odd indeed..:/ 
  • Samuel PinchesSamuel Pinches Posts: 1,761Administrator
    Can you give us a few more details - what operating system, what driver you’re using? Does the com port show up in device manager when you plug the printer in? What does it show then?
  • Christiaan VeeningChristiaan Veening Posts: 5Member
    I am operating on Windows 10. The arduino IDE and pronterface both refuse connecting, while the printer perfectly follows the Gcode on my usb stick. COM port  does shows up, it shows as:

    I am apperently using a matterhackers driver?

    I also tried changing the COM port, but the same issue remains.
  • Christiaan VeeningChristiaan Veening Posts: 5Member
    edited May 27
    WOW! Thanks @Samuel Pinches for bringen that up! Somehow my mattercontrol driver conflicted with the driver that is supposed to be used for communicating towards the motherboard. By manually deleted the driver and installing the correct driver again the communcation restored.

    And regarding my thermal runaway: Probably a faulty thermistor, for which I ordered new ones. Thx!
    Post edited by Christiaan Veening on
  • Samuel PinchesSamuel Pinches Posts: 1,761Administrator
    Glad you found the cause :smiley:
Sign In or Register to comment.