A5 motors are not moving after repairing fried MKS board

I had my 2 days old A5 giving a voltage spike when I first connected my USB cable (at USB3.0 connector on my PC I used 1000 times before) to the printer, which caused some spark at the USB port, smoke and burnt a part near to the USB connector, see picture:

After 2 weeks I finally got yesterday a new MKS main board and changed it, but no motor is moving.
I can push HOME, Move button, extrude etc., but nothing is working or moving
Fans are moving, heating nozzle is working, PS gives 24V as it should, stepper driver show at least VRef voltage (just Y axis was down to 0,32V?!). I could flash MKS board with latest Marlin for A5, LCD is also working, at least I could flash customized FW.
I have no idea, as it seems that everything else is working normal.
Checked already some cable, but found no shirtage etc.


BTW: I could even flash latest Marlin the burnt board, but some communication seems to be broken at least, as I do not get all Mxxx codes answered back....

Could all stepper drivers or motors at once have suffered from this little voltage pike? USB 3.0 is no prividing so much I would think it could harm these parts at all.
I was never afriad connecting USB while printer is switched on, somehow I'm afraid now .... :/

Your ideas are welcome, I was looking desperatly to my open printer for hours, hoping I will find a loose cabel, burnt things which I could repair...
Thanks
Malte








Comments

  • Samuel PinchesSamuel Pinches Posts: 2,695Administrator
    Can you connect your printer to the computer, and try to control it using pronterface?   Do you get any error messages when you try to do that ?  Have you tried homing the axes first?
  • hundemannhundemann Posts: 5Member
    I have tried homing axes first via printer LCD, but nothing is moving.
    And as I mentioned, I am already a bit afraid connecting to computer while printer is on due to bad experince (sound stupid I know)....but I think I should try this.

    If control by pronterface will be possible, then something could be wrong with my LCD I guess?! I can push buttons, go through the menus though...
  • Samuel PinchesSamuel Pinches Posts: 2,695Administrator
    Im sorry I don't have any other suggestions! The MKS lcd does not show error messages like the normal 3D printer LCD's do, so the only option is to connect it to a computer... maybe a laptop or different computer?
  • hundemannhundemann Posts: 5Member
    Using pronterface didn't make the motors move, was not working.
    But: I found that somehow also my stepper driver for Y  was fried, it was getting very hot and didn't show same Vref than on X.
    S
    o I just swapped Y and X to TMC2130 V1.1 which I had planned anyway. Wired them up and tried again.
    After switching on, my X was going to Home again, but just hitting the endstop relay, not moving to the other direction.
    Y and Z didn't move at all.
    After playing a bit around I dared to connect USB while printer is on (I have to say I tried before, but without Z and X connected, but on the open main case with just Y motor), printer was rebooting and sh.... small pop noise, bad smell..... :# , which ended not in a fried MKS board this time, but fried my TMC2130 on Y.

    Oh man, I'm lost.......... :'(
    How can I check the motor on Y is ok and not causing a short etc.?!

  • Samuel PinchesSamuel Pinches Posts: 2,695Administrator
    Do you have a multimeter? These stepper motors have 4 pins, that are in two coils. You can put the multimeter in resistance mode, and check the resistance between each combination of the motor pins (while the motor is unplugged!!)

  • hundemannhundemann Posts: 5Member
    Hi Samuel,
    thanks for all your input and support.
    I quickly checked all motors, so all of them show resistance in the pair of yellow&white / black&red, I guess they are ok.
    I'm going now through the cables, because I still have no clue why Y got so hot and killed my stepper drivers, I still assume I have a short somewhere...it is pain in the ass.
    On the main case I unplugged all cables and measured them, seems main case is clear...now the X,Z, and E0 Arm is next...

    Claimed at Gearbest where I purchased already from the beginning, but yeah, finally they sent out a new MKS board for free!!, I wanted them to exchange the total machine....would have been much better,
  • Samuel PinchesSamuel Pinches Posts: 2,695Administrator
    Sounds frustrating 😔 good luck, let us know how you go.
  • hundemannhundemann Posts: 5Member
    edited May 2018
    Hi Samuel,
    I posted already on the FB group, almost forgot to complete the story also here:
    My JGAurora is back to life again for some ~week already, it seems first shortage was caused but a not properly insulated hot-end NTC.
    This fried my first MKS board AND the original stepper drivers (which I did not recognize in the beginning).
    I initially thought that just one driver has died, because it did not show any good VREF value anymore.
    So I started to replacing them to TMC2130 V1.1, but also killed two of the drivers in that process, and just then I found the NTC was blown, so after replacing it to a new one, putting in the protection boards for the TMC drivers, and finally getting the replacement board from GB incl. 4 new stepper drivers, I found out that all my original drivers were also fried. Thanks to Aliexpress and shipment time of ~8 days to Germany, I could revive the beast again..

    So I'm now printing and printing..my two sons have a lot of orders as you might guess ;-).
    Installed also the IR Autolevelling probe from Escher3D...
    Just now my X-Axis bearing (at least the LM8LUU large) is slowly dying and makes a lot of noise, ordered already a Misumi one for replacement + some LM8LUU normal ones as IGUS Drylin.
    So happy again and thanks for all your input.
    Post edited by hundemann on
  • Samuel PinchesSamuel Pinches Posts: 2,695Administrator
    Thanks for sharing the update! :) some good progress it seems.
Sign In or Register to comment.