JGAURORA JGMaker Magic Promotion


NEW Budget 3D Printer: JGMaker Magic
The best deal at the moment is from Gearbest, who are running a flash sale for just $179!
Amazon USA also is offering an $30 instant discount coupon on the JGAurora Magic - a great option for those who want it even faster!

JGAURORA A5S Deals


[6th Jun 19] The LATEST JGAurora A5S is already for sale under $400 - use coupon GBA5S11 for a further $15 off!
Print quality is better than A5 out of the box, and it only takes 10 minutes to assemble.
Click here to check out this deal!

one way only movements

gary74gary74 Posts: 7Active Member
recently I replaces my MKS. GEN V1.0 BOARD & MY MKS TFT28 V3.0  After flashin with the older  201 april 16 malrin in my arduino. I get no movement in any negative direction. I get  movement in the positive directions but no return. I have tried checking all wiires and connectors. What am I missing? Please help. I have new motor stepper drivers coming but I want all else up to par. Someon please leae me some kind of way to identify why this will not move in the return or negative directions. 

Comments

  • gary74gary74 Posts: 7Active Member
    This is an A5 and the date of the flash was april 16 2018
  • Samuel PinchesSamuel Pinches Posts: 2,147Administrator
    Have you tried to home the axis?
    Cheers,
    Sam

    Thanked by 1gary74
  • gary74gary74 Posts: 7Active Member
    yes I did but it only makes noise in the Zaxis. After the different motors are past the homing point they will not return.
    If I move the y table below it will move it in the right direction. I also can move the x axis as long as it is in just the positivge direction. . 
    I recentely had this machine given to me because it had stopped working. I found the power supply was out. I replaced it Then I had no screen when it was hooked up and bought a new mks tft28 touch screen. I got it on and flashed it with the latest version in the JG wiki and nothing would move. 
    I got a new board. MKS GEN_L VG1.0 BOARD.
    Then I checkeck ed the voltage on the motor steppers. All seemed in good ranges. It moved the z axis up and I noticed the axis was not level and then noticed that it did not have the 4.mm set screws in either. I got those yesterday. I finally checked all the wire plugs and put it all back together. I cannot find a loose or unplugged connection. I have learned a lot thru the videoes of various people. I looked at the basics on the board. 
    Ihavre ordered and await new stepper motor drivers. TMC2208. I am now wondering if i need to get new harnesses for the whole the thing.
  • GandyGandy Posts: 57🌟 Super Member 🌟
    Does any one of the motors work? If yes, you could try to identify if the problem is with the driver or the motor/cabling:

    Say it is X that is working and Y is not. Exchange X and Y motor cables on the board (power off before disconnecting/ connecting motors) and check which motor is working. If you can move the Y-motor with the X-driver, the fault probably lies with the Y-driver. If you can move the X-motor with the Y-driver, it's more likely the cabling to the Y-motor ir the Y-motor itself. To see if it is the cable or the motor, you would now want to use the X-driver with X-cable connected to the Y-motor.

    Other than that, you could try checking the endstops with M119  - you could even try to issue a M121 to disable the endstops and carefully try to move your axes. You may need to also switch off software endstops with M211. Just make sure to enable all of these again after testing.

    Remember that after installing the TMC2208 your stepper directions will change as the drivers use a different pinout compared to the Pololu A4988. You'll have to adapt the marlin configuration to account for that and recompile it. There are good videos on how to do that. Also, consider using the TMC2208 in UART mode, where you can fine-tune the motor voltages in software. See Upgrade to TMC2208 Stepper Drivers for details.
Sign In or Register to comment.