How to use Mesh Bed Leveling on Custom Firmware

Samuel PinchesSamuel Pinches Posts: 2,271Administrator
This post is a guide on how to use mesh bed levelling on an A5S or A1 running the custom Marlin 2.0 firmware.

This post is brief, please post questions below if there are any aspects that are unclear.

1. Install custom firmware
2. Edit your slicer start gcode. Ensure there is a line that says "M420 S1". This line should be placed after any G28 (homing) command, as homing typically disables the mesh bed leveling function.
3. Ensure an SD card is inserted in the printer. The settings are saved on the SD card.
4. Preheat the bed to your normal printing temperature. Leave the printer for 15 minutes to fully warm up to temperature.
5. Level the bed manually, using a piece of paper between the nozzle and the bed. The nozzle should be slightly dragging on the paper. Level for all 4 corners. Don't worry about the center, as we will take care of that with the mesh bed leveling.
6. Use the menu to find the mesh bed leveling wizard. It will guide you through storing the mesh leveling height for 25 points across the bed.
7. Check the leveling menu, that Mesh Bed Leveling is Enabled.
8. Use the move axis function to check that the nozzle height is correctly following the mesh across the bed surface.
9. Choose the "Save Configuration" menu option. This will save the settings to the SD card.
10. Restart the printer. The printer should automatically load the settings from the SD card.
11. Check the bed levelling menu: ensure that mesh bed levelling is enabled. If not, enable it.
12. Use the move axis function to check that the nozzle height is still correctly following the mesh across the bed surface.
13. If it all works, then you are ready to try a test print!

Thanked by 1aestrems
Post edited by Samuel Pinches on


  • SparkSpark Posts: 49🌟 Super Member 🌟
    Number 7 - Checking the menu to make sure that Mesh Bed Leveling is ON. 
    Under Motion, I have a sub-menu for Bed Leveling.  When I go into that I have:
    Level Bed --> This makes me do the mesh bed leveling
    Edit Mesh -->  index x - index y -  Value  Z
    Fade Height
    Bed Z
    Load Settings
    Save Settings

    There is NOT an option that says Mesh bed leveling on or off


    If I then level the bed - save it - the option appears.  If I then turn the printer OFF, then go back to the option it is missing.  If I go and level the corners - save the corners - the option appears again but is OFF.  I can turn it back ON but if I turn the printer OFF then back ON the option is again missing. 

    If I hit load settings I am unsure if it is loading anything.  

    Once I level the bed or the corners My options Under Motion -> bed leveling change to:
    Level Bed -
    Edit Mesh
    Bed Leveling: ON
    Fade Height:
    Bed Z:
    Level Corners
    Load Settings
    store Settings

  • mnowak1033mnowak1033 Posts: 1Member
    Can some one help me?
    I heave the same problem like "Spark" ...
  • Samuel PinchesSamuel Pinches Posts: 2,271Administrator
    Welcome @mnowak1033 - can you please try the firmware Beta 6 and see if you have the same problem with the settings not being saved on reboot. I simply haven't had time to look into it unfortunately.
  • poikilospoikilos Posts: 10Member
    edited November 2019
    Are the instructions exactly the same for A3S? I have the board and LCD community firmwares. The menu has Mesh Up and Mesh Down but I haven't tried them.
    Post edited by poikilos on
  • Samuel PinchesSamuel Pinches Posts: 2,271Administrator
    Welcome @poikilos - the instructions above are just for the 32 bit firmware on A5S, A1 and A3S (V2). 

    The process for the A5 and A3S (V1) is on the wiki here:

    Thanked by 1poikilos
  • poikilospoikilos Posts: 10Member
    Using Pronterface method, what if after sending the index I send a G-Code to do a relative move by Y51 (for using [JGAURORA A3S Dial Indicator Mount for Bed Tramming + hardware (fasteners)](, will everything still work and set the mesh point correctly?
Sign In or Register to comment.