Custom FW z-axis noisy

Hello,
I poped the latest FW both for the LDC and the main board as of Dec 2019.
After upload, I tried to level, but during leveling, I also tried moving z-axis in a 10mm increment. I notice the motor is noisy and it seems that there is a resistance (friction) when moving upward. The downward motion is not a problem.
Initially, I thought that there is resistance.
Then I tried to use the default FW, the noise and resistance is not there!
It seems that the movement going up using the CUstom FW, is having resistance effect, but actually there is not!
It seems to wobble so the effect of resistance is there!
What could be the problem internally, could it be the Vref?

Tnx!

Comments

  • Samuel PinchesSamuel Pinches Posts: 2,281Administrator
    Hi @victagayun - I'm not sure what you mean. The speeds are different between factory and custom firmwares and this could make things sound difference. What do you mean by friction/resistance? I'm not sure I understand. Vref tuning is good regardless of if using factory or custom firmwares, as is adding better lubrication to the axis.
  • victagayunvictagayun Posts: 15Member
    When I move up, it seems that the motor is exerting effort to move like there was friction.
    You can hear the noise of the motor, seems to be stuck somewhere that is why there is moto noise or vibration.
    But when I change to factory FW, it seems to be ok.
    BTW, I used the one in the dropbox. 
    I move 10mm increment, moving up and down. Going down is ok, except going up.
  • Samuel PinchesSamuel Pinches Posts: 2,281Administrator
    edited December 2019
    Hmmm.... that makes very little sense to me that there is a difference with the factory firmware and the custom one with respect to friction. The firmware has zero control over stepping, microstepping, or motor power. Only speed and acceleration. I would suggest cleaning off the low quality blue "goop" that jgaurora uses on the Z axis and replacing with a better, high performance lubricant. You could try tuning the Z axis vref too. I'm sorry I have absolutely zero idea what could be causing a difference between the firmware on the A5.
    Post edited by Samuel Pinches on
  • victagayunvictagayun Posts: 15Member
    As I have mentioned, there is no "real" friction.
    The movement using the Custom FW makes it look like there is friction when it moves.
    When I have the chance, I will take video.
  • Laser8302Laser8302 Posts: 101Member, 🌟 Super Member 🌟
    If you have Pronterface, send M203 Z10 (set max feedrate of Z-axis to 10mm/s) and see if that helps. You can go up from there. I found my printer likes between 10-15mm/s feedrate for the Z-axis. Save the new setting with M500.
Sign In or Register to comment.