A5 heatbed stop heat up problem

RobertRobert Posts: 33🌟 Super Member 🌟

I hope you can answer this question,  my A5 have perform well since I got on January of this year, the last few week I've notice the heat bed will shut off during pre-heat or in the start of new print; and it just did it again as I am typing this message.  I already change to a new heat bed today and the problem continued, so its not the heat bed. 

Is this a board issue or a power supply issue, I have extra power supply I can replace but if is  a board issue I will have to  get a new one and go through the whole upgrade to the custom firmware again. 

For what I can tell it looks like a power issue, as soon as the extruder motor is engaging the power on the heat bed will cut off and the whole thing comes to a stop, I am just lucky it has happen during mid pint yet,  I don't want to take a chance on that.

Any ideas?



  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    Hi Robert,
    welcome to the forum :)
    for starters, the LCD interface is useless for troubleshooting, as it does not display error messages. Have a read here about troubleshooting with pronterface:


  • RobertRobert Posts: 33🌟 Super Member 🌟
    Hi Samuel,

    Thanks for replying, I was going to do that next.
    Right now the heatbed is not working again, it won't heat up. 
    When I try to heat the bed via the LCD I can see the red LED lights up on the motherboard, when I turn off the heater the LED goes off. 

    I will do the pronterface and post the finding here hopefully we can figure this out.

  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    When the printer stops, it usually produces an error message. Pronterface will show you the answer, and we can go from there. Best, Sam
  • RobertRobert Posts: 33🌟 Super Member 🌟
    Here are the errors:

    Error:Heating failed, system stopped! Heater_ID: bed
    [ERROR] Error:Heating failed, system stopped! Heater_ID: bed

    Error:Printer halted. kill() called!
    [ERROR] Error:Printer halted. kill() called!

  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    edited May 2018
    Error Translation: I turned on the bed heater, and did not detect any (or as much of an) increase in temperature as I expected, so I shut down for safety to avoid burning your house down.

    Possible Causes:
    • The thermistor sensor cable is broken: place your hand or a warm cup of coffee on the centre of the print bed, if the temperature increases slightly then this is not the case.
    • The bed heater power cables are broken: does your printer have a cable chain? if yes, then this is the most likely failure. Check the resistance of the heater cables.
    • the mosfet that controls the heater element is broken: unlikely, but can check by turning on bed heater, and measuring output voltage from motherboard bed outputs.

    You said you saw the red light turn on on the motherboard. But, there is an LED under the heating bed which is connected to the bed heater power wires - does that LED turn on?

    The most likely failure in my mind is a failure of the bed heating cables.

    Post edited by Samuel Pinches on
  • RobertRobert Posts: 33🌟 Super Member 🌟
    My has the cable chain.

    When the bed is working the light under the bed light up, then it would turn off.  Right now the bed is not working, but if I turn off the printer wait a bit then turn it back on the bed will heat up then it goes off again sometime during the heat up process. 

    How can the  heater cable be broken? 
    I will open it up in the morning and measure the power on the bed output. its 3:30am here in Los Angeles. 

    If the bed heating cable is bad, there are four wires on the bed power plug, two for power and two for temp, which one is bad the power?
    If the power output from the board is  24V, can I replace the power cable and get it going again?
    or how would you suggest I fix the cable problem?

  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    edited May 2018
    Go to bed man!!! :dizzy:

    Take things one step at a time. From your description, this is not a problem with the motherboard, this is almost definitely a problem with the bed or the cables. I wouldn't bother measure the bed output.
    1. Disassemble the printer, unplug all cables, and separate the main chassis from the upright.
    2. Open the main chassis (3 small screws at back, 2 screws in front feet, and 2 small screws at front bottom).
    3. Unplug the y-endstop and y-motor cables, and disconnect the LCD cables from the motherboard.
    4. Disconnect the bed heater and bed thermistor cables from the motherboard.
    5. Unscrew the cable chain. To remove these cables you may need to cut several cable ties.
    6. Disconnect the cable from the bed heater itself - be very careful, the connector is not soldered onto the bed well, and pulling on the connector can rip the connector off the bed.
    7. Unthread the heater cable from the cable chain. Inspect the cable. Measure the resistance of each of the two thick wires.

    Several people have had this problem, as the cable chain is supposed to prevent flexing of the wires occuring in the same place every time. Unfortunately, JGAurora used high quality, but very flexible silicone wires, and this cable chain instead CAUSES a problem in these printers. The cable chain is a GOOD idea, but to fix the design flaw, you need to add some kind of semi-rigid or springy rod (e.g. a length of PTFE tubing) to help the cable chain move smoothly, and not just bend at one point.

    Replacement silicone wire: "12AWG silicone wire" e.g. http://r.ebay.com/ZyGfN6
    Example of reinforcing PTFE tubing - to place in the cable chain too: http://r.ebay.com/ODW8oI
    Post edited by Samuel Pinches on
  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    edited May 2018
    Here is an example from another customer with the same problem of what to look out for.

    Post edited by Samuel Pinches on
  • RobertRobert Posts: 33🌟 Super Member 🌟
    It is the dame wire, the positive wire is broken, when I pull the wire out of the chain is just came out .
    The wire is a 16AWG and is not even a silicone wire, just a regular electrical wire and the it looks burn where is broke off.
    I have 16AWG silicone wire I used for my RC car/plane battery so I will replace it with. 

  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    Just remember you need to add some kind off springy stiffer rod to prevent this happening in the same spot again.
  • RobertRobert Posts: 33🌟 Super Member 🌟

    Once again thank you for all your help, I got it fix.
    I replace the bed power cable to a silicone wire and it won't break like the OEM cable, the temp wire is silicone that's why it did not break.  I mention this to Jgaurora tech support, they told me they are aware of the issue and have gone ahead fixed the problem,  I am assuming they replace to a better wire in the factory.
  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    That’s great to hear Robert - happy printing :) 

    p.s JGAurora removed the cable chain from future printers 😭
  • caligariuscaligarius Posts: 3Member
    Hey Guys,

    i just red this thread, because I have nearly the same problems.
    My printer (JGAuroraA5) has stopped printing from one moment to the next.
    I installed pronterface and tried to print... here is the error-code:

    Error:Heating failed, system stopped! Heater_ID: bed
    [ERROR] Error:Heating failed, system stopped! Heater_ID: bed
    Error:Printer halted. kill() called!
    [ERROR] Error:Printer halted. kill() called!

    So, I opened the printer to check cables etc... all cables seem to
    be okay. no cable chain ;-) hahaha.
    Do you have some idea what to do next?
    I also tried the trick with a hot cup of tea on the bed... but the temp will not increase!?

    Best regards,
  • Samuel PinchesSamuel Pinches Posts: 2,628Administrator
    Welcome @caligarius !

    It sounds like a problem with the bed thermistor, or perhaps the bed temperature sensor port on the motherboard.

    Have a read on the wiki here for starters, and then feel free to ask any questions: https://jgaurorawiki.com/a5/faulty-temperature-readings

    Thanked by 1caligarius
  • caligariuscaligarius Posts: 3Member
    Hey Sam,

    thank you for your hyperspeed-reply :)

    I just measured the thermistors (both has about 100k ohms).
    Then I changed the bed thermistor plug to the spare-plug on the board, changed the pins in the arduino software,
    but already the same problem. I updated the TFT-firmware to the newest custom-firmware... so now the printer shows
    the error by itself without pronterface :p
    Still trouble with the heating of bed...
    BUT now I found that:
    I think this will be the problem... but I was not able to see it before I loosen the heatbed from the frame.
    I will try to disconnect this plug (damn this glue) and make it fresh...

    Thank you for your support!

    Kind regards,
  • cs2000cs2000 Posts: 56🌟 Super Member 🌟
    edited May 2019

    If your printer is under warranty, contact JGAurora, they will replace that with the new heated bed and connector which has 6 pins rather than the 4 you have.

    If not, you can buy these items from their online stores.

    Post edited by cs2000 on
  • caligariuscaligarius Posts: 3Member
    unfortunately it is not under warranty... so first I´ll try to solder a
    new connection to the hotbed.
Sign In or Register to comment.